aboutsummaryrefslogtreecommitdiff
path: root/virtual/modules/websites/chloe.nix
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/modules/websites/chloe.nix')
-rw-r--r--virtual/modules/websites/chloe.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/virtual/modules/websites/chloe.nix b/virtual/modules/websites/chloe.nix
new file mode 100644
index 0000000..2c0c65d
--- /dev/null
+++ b/virtual/modules/websites/chloe.nix
@@ -0,0 +1,27 @@
1{ lib, pkgs, config, mylibs, ... }:
2let
3 cfg = config.services.myWebsites.Chloe;
4in {
5 options.services.myWebsites.Chloe = {
6 production = {
7 enable = lib.mkEnableOption "enable Chloe's website in production";
8 };
9 integration = {
10 enable = lib.mkEnableOption "enable Chloe's website in integration";
11 };
12 };
13
14 config = lib.mkMerge [
15 (lib.mkIf cfg.production.enable {
16 security.acme.certs."chloe" = config.services.myCertificates.certConfig // {
17 domain = "osteopathe-cc.fr";
18 extraDomains = {
19 "www.osteopathe-cc.fr" = null;
20 };
21 };
22 })
23 (lib.mkIf cfg.integration.enable {
24 security.acme.certs."eldiron".extraDomains."chloe.immae.eu" = null;
25 })
26 ];
27}