aboutsummaryrefslogtreecommitdiff
path: root/systems/eldiron/websites/vpn/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'systems/eldiron/websites/vpn/default.nix')
-rw-r--r--systems/eldiron/websites/vpn/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/systems/eldiron/websites/vpn/default.nix b/systems/eldiron/websites/vpn/default.nix
new file mode 100644
index 0000000..ea54691
--- /dev/null
+++ b/systems/eldiron/websites/vpn/default.nix
@@ -0,0 +1,13 @@
1{ lib, pkgs, config, ... }:
2let
3 cfg = config.myServices.vpn;
4in {
5 config = lib.mkIf cfg.enable {
6 security.acme.certs.eldiron.extraDomainNames = [ "vpn.immae.eu" ];
7 services.websites.env.tools.vhostConfs.vpn = {
8 certName = "eldiron";
9 hosts = [ "vpn.immae.eu" ];
10 root = ./www;
11 };
12 };
13}