aboutsummaryrefslogtreecommitdiff
path: root/systems/eldiron/websites/vpn/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /systems/eldiron/websites/vpn/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'systems/eldiron/websites/vpn/default.nix')
-rw-r--r--systems/eldiron/websites/vpn/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/systems/eldiron/websites/vpn/default.nix b/systems/eldiron/websites/vpn/default.nix
new file mode 100644
index 0000000..ea54691
--- /dev/null
+++ b/systems/eldiron/websites/vpn/default.nix
@@ -0,0 +1,13 @@
1{ lib, pkgs, config, ... }:
2let
3 cfg = config.myServices.vpn;
4in {
5 config = lib.mkIf cfg.enable {
6 security.acme.certs.eldiron.extraDomainNames = [ "vpn.immae.eu" ];
7 services.websites.env.tools.vhostConfs.vpn = {
8 certName = "eldiron";
9 hosts = [ "vpn.immae.eu" ];
10 root = ./www;
11 };
12 };
13}