aboutsummaryrefslogtreecommitdiff
path: root/pkgs/webapps/yourls/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/webapps/yourls/default.nix')
-rw-r--r--pkgs/webapps/yourls/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/webapps/yourls/default.nix b/pkgs/webapps/yourls/default.nix
index cc880cd..4bcfa4c 100644
--- a/pkgs/webapps/yourls/default.nix
+++ b/pkgs/webapps/yourls/default.nix
@@ -6,8 +6,10 @@ let
6 builtins.concatStringsSep "\n" ( 6 builtins.concatStringsSep "\n" (
7 map (value: "ln -s ${value} $out/user/plugins/${value.pluginName}") plugins 7 map (value: "ln -s ${value} $out/user/plugins/${value.pluginName}") plugins
8 ); 8 );
9 passthru.plugins = plugins; 9 passthru = old.passthru // {
10 passthru.withPlugins = morePlugins: old.withPlugins (morePlugins ++ plugins); 10 inherit plugins;
11 withPlugins = morePlugins: old.withPlugins (morePlugins ++ plugins);
12 };
11 }); 13 });
12 package = stdenv.mkDerivation (mylibs.fetchedGithub ./yourls.json // rec { 14 package = stdenv.mkDerivation (mylibs.fetchedGithub ./yourls.json // rec {
13 installPhase = '' 15 installPhase = ''