aboutsummaryrefslogtreecommitdiff
path: root/pkgs/webapps/peertube/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/webapps/peertube/default.nix')
-rw-r--r--pkgs/webapps/peertube/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/pkgs/webapps/peertube/default.nix b/pkgs/webapps/peertube/default.nix
index 7889cee..3642a44 100644
--- a/pkgs/webapps/peertube/default.nix
+++ b/pkgs/webapps/peertube/default.nix
@@ -1,4 +1,4 @@
1{ ldap ? false, sendmail ? false, light ? null, runCommand, libsass 1{ ldap ? false, sendmail ? false, light ? null, syden ? false, runCommand, libsass
2, lib, stdenv, rsync, fetchzip, youtube-dl, fetchurl, mylibs, python, nodejs, nodePackages, yarn2nix-moretea }: 2, lib, stdenv, rsync, fetchzip, youtube-dl, fetchurl, mylibs, python, nodejs, nodePackages, yarn2nix-moretea }:
3let 3let
4 nodeHeaders = fetchurl { 4 nodeHeaders = fetchurl {
@@ -8,7 +8,10 @@ let
8 source = mylibs.fetchedGithub ./peertube.json; 8 source = mylibs.fetchedGithub ./peertube.json;
9 patchedSource = stdenv.mkDerivation (source // rec { 9 patchedSource = stdenv.mkDerivation (source // rec {
10 phases = [ "unpackPhase" "patchPhase" "installPhase" ]; 10 phases = [ "unpackPhase" "patchPhase" "installPhase" ];
11 patches = [ ./yarn_fix_http_node.patch ] ++ lib.optionals ldap [ ./ldap.patch ] ++ lib.optionals sendmail [ ./sendmail.patch ]; 11 patches = [ ./yarn_fix_http_node.patch ]
12 ++ lib.optionals ldap [ ./ldap.patch ]
13 ++ lib.optionals sendmail [ ./sendmail.patch ]
14 ++ lib.optionals syden [ ./syden.patch ];
12 installPhase = let 15 installPhase = let
13 # Peertube supports several languages, but they take a very long 16 # Peertube supports several languages, but they take a very long
14 # time to build. The build script accepts --light which builds 17 # time to build. The build script accepts --light which builds
@@ -37,9 +40,6 @@ let
37 ''; 40 '';
38 41
39 yarnModulesConfig = { 42 yarnModulesConfig = {
40 # all = {
41 # buildInputs = [ yarn2nix-moretea.yarn2nix.src ];
42 # };
43 bcrypt = { 43 bcrypt = {
44 buildInputs = [ nodePackages.node-pre-gyp ]; 44 buildInputs = [ nodePackages.node-pre-gyp ];
45 postInstall = let 45 postInstall = let