aboutsummaryrefslogtreecommitdiff
path: root/pkgs/webapps/nextcloud/apps/cookbook.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/webapps/nextcloud/apps/cookbook.nix')
-rw-r--r--pkgs/webapps/nextcloud/apps/cookbook.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/pkgs/webapps/nextcloud/apps/cookbook.nix b/pkgs/webapps/nextcloud/apps/cookbook.nix
new file mode 100644
index 0000000..adc47c2
--- /dev/null
+++ b/pkgs/webapps/nextcloud/apps/cookbook.nix
@@ -0,0 +1,13 @@
1{ buildApp }:
2buildApp rec {
3 appName = "cookbook";
4 version = "0.5.4";
5 url = "https://github.com/mrzapp/nextcloud-cookbook/releases/download/v${version}/${appName}.tar.gz";
6 sha256 = "1dav07jylmw9n05l7p3m20ywky27nrg3gna271mly5bvs9q6kanm";
7 installPhase = ''
8 sed -i -e "s/application..ld..json/application[^\"|\\\\']*ld[^\"|\\\\']*json/" lib/Service/RecipeService.php
9 mkdir -p $out
10 cp -R . $out/
11 '';
12}
13