aboutsummaryrefslogtreecommitdiff
path: root/pkgs/tiv
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tiv')
-rw-r--r--pkgs/tiv/default.nix19
-rw-r--r--pkgs/tiv/tiv_builder.sh8
2 files changed, 0 insertions, 27 deletions
diff --git a/pkgs/tiv/default.nix b/pkgs/tiv/default.nix
deleted file mode 100644
index 3e7a56c..0000000
--- a/pkgs/tiv/default.nix
+++ /dev/null
@@ -1,19 +0,0 @@
1{ buildPerlPackage, fetchurl, perlPackages }:
2buildPerlPackage rec {
3 pname = "tiv";
4 version = "2015";
5 src = fetchurl {
6 url = "http://xyne.archlinux.ca/projects/tiv/src/tiv-${version}.tar.xz";
7 sha256 = "1vq073v7z7vmcd57lhs4rf4jasji69cpjgkz4dykp94a77p1qq90";
8 };
9
10 outputs = ["out"];
11 buildInputs = with perlPackages; [ PerlMagick ];
12 perlPreHookScript = ./tiv_builder.sh;
13 perlPreHook = ''
14 source $perlPreHookScript
15 '';
16 installPhase = ''
17 install -Dm755 tiv "$out/bin/tiv"
18 '';
19}
diff --git a/pkgs/tiv/tiv_builder.sh b/pkgs/tiv/tiv_builder.sh
deleted file mode 100644
index ea16682..0000000
--- a/pkgs/tiv/tiv_builder.sh
+++ /dev/null
@@ -1,8 +0,0 @@
1orig=$(declare -f preConfigure)
2new_name="preConfigure2 ${orig#preConfigure}"
3eval "$new_name"
4
5preConfigure() {
6 preConfigure2 || true
7}
8