aboutsummaryrefslogtreecommitdiff
path: root/pkgs/terminal-velocity/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/terminal-velocity/default.nix')
-rw-r--r--pkgs/terminal-velocity/default.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/pkgs/terminal-velocity/default.nix b/pkgs/terminal-velocity/default.nix
deleted file mode 100644
index 1a015c0..0000000
--- a/pkgs/terminal-velocity/default.nix
+++ /dev/null
@@ -1,37 +0,0 @@
1{ python36Packages }:
2with python36Packages;
3buildPythonApplication rec {
4 pname = "terminal-velocity-git";
5 version = "0.2.0";
6 src = fetchPypi {
7 inherit pname version;
8 sha256 = "13yrkcmvh5h5fwnai61sbmqkrjyisz08n62pq0ada2lyyqf7g6b9";
9 };
10
11 patches = [
12 ./sort_found_notes.patch
13 ./python3_support.patch
14 # FIXME: update this patch when version changes
15 ./fix_build.patch
16 ];
17
18 preCheck = ''
19 # Needed for urwid test
20 export LC_ALL=en_US.UTF-8
21 '';
22 propagatedBuildInputs = [
23 chardet
24 urwid
25 (sh.overridePythonAttrs { doCheck = false; })
26 pyyaml
27 ];
28 buildInputs = [
29 m2r
30 (restructuredtext_lint.overridePythonAttrs { doCheck = false; })
31 pygments
32 ];
33
34 postInstall = ''
35 rm $out/bin/terminal_velocity
36 '';
37}