aboutsummaryrefslogtreecommitdiff
path: root/pkgs/telegramircd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/telegramircd/default.nix')
-rw-r--r--pkgs/telegramircd/default.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/pkgs/telegramircd/default.nix b/pkgs/telegramircd/default.nix
deleted file mode 100644
index 2f1d7ca..0000000
--- a/pkgs/telegramircd/default.nix
+++ /dev/null
@@ -1,16 +0,0 @@
1{ openssl, telethon, python3Packages, mylibs }:
2with python3Packages;
3buildPythonApplication rec {
4 format = "other";
5 pname = "telegramircd";
6 version = "master";
7 propagatedBuildInputs = [ telethon aiohttp ConfigArgParse openssl ];
8 src = (mylibs.fetchedGithub ./telegramircd.json).src;
9 LD_LIBRARY_PATH = "${openssl.out}/lib";
10 installPhase = ''
11 install -D $src/telegramircd.py $out/bin/telegramircd
12 wrapProgram "$out/bin/telegramircd" \
13 --prefix LD_LIBRARY_PATH : "${openssl.out}/lib"
14 install -Dm644 "$src/config" -t "$out/etc/telegramircd/"
15 '';
16}