aboutsummaryrefslogtreecommitdiff
path: root/pkgs/notmuch/notmuch-python
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/notmuch/notmuch-python')
-rw-r--r--pkgs/notmuch/notmuch-python/default.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/pkgs/notmuch/notmuch-python/default.nix b/pkgs/notmuch/notmuch-python/default.nix
deleted file mode 100644
index d639d9a..0000000
--- a/pkgs/notmuch/notmuch-python/default.nix
+++ /dev/null
@@ -1,16 +0,0 @@
1{ stdenv, notmuch, pythonPackages }:
2stdenv.mkDerivation rec {
3 name = "notmuch-${pythonPackages.python.name}-${version}";
4 version = notmuch.version;
5 outputs = [ "out" ];
6 buildInputs = with pythonPackages; [ sphinx python ];
7 src = notmuch.src;
8 phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
9 buildPhase = ''
10 cd bindings/python
11 python setup.py build
12 '';
13 installPhase = ''
14 python setup.py install --prefix=$out --optimize=1
15 '';
16}