aboutsummaryrefslogtreecommitdiff
path: root/overlays/python-packages/apprise
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/python-packages/apprise')
-rw-r--r--overlays/python-packages/apprise/apprise.json15
-rw-r--r--overlays/python-packages/apprise/default.nix16
2 files changed, 31 insertions, 0 deletions
diff --git a/overlays/python-packages/apprise/apprise.json b/overlays/python-packages/apprise/apprise.json
new file mode 100644
index 0000000..b408ea4
--- /dev/null
+++ b/overlays/python-packages/apprise/apprise.json
@@ -0,0 +1,15 @@
1{
2 "tag": "c9b957c-master",
3 "meta": {
4 "name": "apprise",
5 "url": "https://github.com/caronc/apprise",
6 "branch": "master"
7 },
8 "github": {
9 "owner": "caronc",
10 "repo": "apprise",
11 "rev": "c9b957c4341e7d43e5be6463bd317a7401d083d9",
12 "sha256": "01zz4mh3xvplrm5xalzrcncnh0jq5y51pmdxkr4hdd6dz9wx0mbg",
13 "fetchSubmodules": true
14 }
15}
diff --git a/overlays/python-packages/apprise/default.nix b/overlays/python-packages/apprise/default.nix
new file mode 100644
index 0000000..99e04ad
--- /dev/null
+++ b/overlays/python-packages/apprise/default.nix
@@ -0,0 +1,16 @@
1self: super: {
2 python3 = super.python3.override {
3 packageOverrides = python-self: python-super: {
4 apprise = python-self.buildPythonPackage rec {
5 pname = "apprise";
6 version = "0.7.4";
7 src = (self.mylibs.fetchedGithub ./apprise.json).src;
8 propagatedBuildInputs = with python-self; [ decorator
9 requests requests_oauthlib oauthlib urllib3 six click
10 markdown pyyaml sleekxmpp
11 ];
12 doChecks = false;
13 };
14 };
15 };
16}