aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/tools/tools/rompr.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/tools/tools/rompr.nix')
-rw-r--r--nixops/modules/websites/tools/tools/rompr.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/nixops/modules/websites/tools/tools/rompr.nix b/nixops/modules/websites/tools/tools/rompr.nix
index 98c48a7..baee2eb 100644
--- a/nixops/modules/websites/tools/tools/rompr.nix
+++ b/nixops/modules/websites/tools/tools/rompr.nix
@@ -14,14 +14,16 @@ let
14 ln -sf ../../../../../../${varDir}/albumart $out/albumart 14 ln -sf ../../../../../../${varDir}/albumart $out/albumart
15 ''; 15 '';
16 }); 16 });
17 apache = { 17 apache = rec {
18 user = "wwwrun"; 18 user = "wwwrun";
19 group = "wwwrun"; 19 group = "wwwrun";
20 modules = [ "headers" "mime" "proxy_fcgi" ]; 20 modules = [ "headers" "mime" "proxy_fcgi" ];
21 webappName = "tools_rompr";
22 root = "/run/current-system/webapps/${webappName}";
21 vhostConf = '' 23 vhostConf = ''
22 Alias /rompr ${webRoot} 24 Alias /rompr ${root}
23 25
24 <Directory ${webRoot}> 26 <Directory ${root}>
25 Options Indexes FollowSymLinks 27 Options Indexes FollowSymLinks
26 DirectoryIndex index.php 28 DirectoryIndex index.php
27 AllowOverride all 29 AllowOverride all
@@ -36,12 +38,12 @@ let
36 </FilesMatch> 38 </FilesMatch>
37 </Directory> 39 </Directory>
38 40
39 <Directory ${webRoot}/albumart/small> 41 <Directory ${root}/albumart/small>
40 Header Set Cache-Control "max-age=0, no-store" 42 Header Set Cache-Control "max-age=0, no-store"
41 Header Set Cache-Control "no-cache, must-revalidate" 43 Header Set Cache-Control "no-cache, must-revalidate"
42 </Directory> 44 </Directory>
43 45
44 <Directory ${webRoot}/albumart/asdownloaded> 46 <Directory ${root}/albumart/asdownloaded>
45 Header Set Cache-Control "max-age=0, no-store" 47 Header Set Cache-Control "max-age=0, no-store"
46 Header Set Cache-Control "no-cache, must-revalidate" 48 Header Set Cache-Control "no-cache, must-revalidate"
47 </Directory> 49 </Directory>