aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/tools/tools/ldap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/tools/tools/ldap.nix')
-rw-r--r--nixops/modules/websites/tools/tools/ldap.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/nixops/modules/websites/tools/tools/ldap.nix b/nixops/modules/websites/tools/tools/ldap.nix
index 82615a7..6cde881 100644
--- a/nixops/modules/websites/tools/tools/ldap.nix
+++ b/nixops/modules/websites/tools/tools/ldap.nix
@@ -42,13 +42,15 @@ rec {
42 ln -sf ${config} $out/config/config.php 42 ln -sf ${config} $out/config/config.php
43 ''; 43 '';
44 }; 44 };
45 apache = { 45 apache = rec {
46 user = "wwwrun"; 46 user = "wwwrun";
47 group = "wwwrun"; 47 group = "wwwrun";
48 modules = [ "proxy_fcgi" ]; 48 modules = [ "proxy_fcgi" ];
49 webappName = "tools_ldap";
50 root = "/run/current-system/webapps/${webappName}";
49 vhostConf = '' 51 vhostConf = ''
50 Alias /ldap "${webRoot}/htdocs" 52 Alias /ldap "${root}"
51 <Directory "${webRoot}/htdocs"> 53 <Directory "${root}">
52 DirectoryIndex index.php 54 DirectoryIndex index.php
53 <FilesMatch "\.php$"> 55 <FilesMatch "\.php$">
54 SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost" 56 SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"