aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/tools/tools/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/tools/tools/default.nix')
-rw-r--r--nixops/modules/websites/tools/tools/default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/nixops/modules/websites/tools/tools/default.nix b/nixops/modules/websites/tools/tools/default.nix
index 41f47a3..0b50a7c 100644
--- a/nixops/modules/websites/tools/tools/default.nix
+++ b/nixops/modules/websites/tools/tools/default.nix
@@ -21,6 +21,9 @@ let
21 shaarli = pkgs.callPackage ./shaarli.nix { 21 shaarli = pkgs.callPackage ./shaarli.nix {
22 env = myconfig.env.tools.shaarli; 22 env = myconfig.env.tools.shaarli;
23 }; 23 };
24 dokuwiki = pkgs.callPackage ./dokuwiki.nix {
25 inherit (mylibs) fetchedGithub;
26 };
24 27
25 cfg = config.services.myWebsites.tools.tools; 28 cfg = config.services.myWebsites.tools.tools;
26in { 29in {
@@ -39,7 +42,8 @@ in {
39 ++ wallabag.apache.modules 42 ++ wallabag.apache.modules
40 ++ yourls.apache.modules 43 ++ yourls.apache.modules
41 ++ rompr.apache.modules 44 ++ rompr.apache.modules
42 ++ shaarli.apache.modules; 45 ++ shaarli.apache.modules
46 ++ dokuwiki.apache.modules;
43 47
44 services.ympd = ympd.config // { enable = true; }; 48 services.ympd = ympd.config // { enable = true; };
45 49
@@ -56,6 +60,7 @@ in {
56 yourls.apache.vhostConf 60 yourls.apache.vhostConf
57 rompr.apache.vhostConf 61 rompr.apache.vhostConf
58 shaarli.apache.vhostConf 62 shaarli.apache.vhostConf
63 dokuwiki.apache.vhostConf
59 ]; 64 ];
60 }; 65 };
61 66
@@ -67,6 +72,7 @@ in {
67 yourls = yourls.phpFpm.pool; 72 yourls = yourls.phpFpm.pool;
68 rompr = rompr.phpFpm.pool; 73 rompr = rompr.phpFpm.pool;
69 shaarli = shaarli.phpFpm.pool; 74 shaarli = shaarli.phpFpm.pool;
75 dokuwiki = dokuwiki.phpFpm.pool;
70 }; 76 };
71 77
72 system.activationScripts = { 78 system.activationScripts = {
@@ -76,6 +82,7 @@ in {
76 yourls = yourls.activationScript; 82 yourls = yourls.activationScript;
77 rompr = rompr.activationScript; 83 rompr = rompr.activationScript;
78 shaarli = shaarli.activationScript; 84 shaarli = shaarli.activationScript;
85 dokuwiki = dokuwiki.activationScript;
79 }; 86 };
80 87
81 systemd.services.tt-rss = { 88 systemd.services.tt-rss = {