aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/tools/mediagoblin/mediagoblin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/tools/mediagoblin/mediagoblin.nix')
-rw-r--r--nixops/modules/websites/tools/mediagoblin/mediagoblin.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixops/modules/websites/tools/mediagoblin/mediagoblin.nix b/nixops/modules/websites/tools/mediagoblin/mediagoblin.nix
index 45bc432..53796d5 100644
--- a/nixops/modules/websites/tools/mediagoblin/mediagoblin.nix
+++ b/nixops/modules/websites/tools/mediagoblin/mediagoblin.nix
@@ -1,4 +1,4 @@
1{ env, makeWrapper, stdenv, writeText, fetchurl, buildBowerComponents, fetchedGit, fetchedGithub, which, python3, pkgs, automake, autoconf, nodejs, nodePackages, git, cacert }: 1{ env, makeWrapper, stdenv, writeText, fetchurl, buildBowerComponents, fetchedGit, fetchedGithub, which, python36, pkgs, automake, autoconf, nodejs, nodePackages, git, cacert }:
2let 2let
3 plugins = { 3 plugins = {
4 basicsearch = stdenv.mkDerivation (fetchedGithub ./mediagoblin-plugin-basicsearch.json // rec { 4 basicsearch = stdenv.mkDerivation (fetchedGithub ./mediagoblin-plugin-basicsearch.json // rec {
@@ -68,11 +68,11 @@ let
68 url = "mirror://pypi/P/PasteScript/${name}.tar.gz"; 68 url = "mirror://pypi/P/PasteScript/${name}.tar.gz";
69 sha256 = "1h3nnhn45kf4pbcv669ik4faw04j58k8vbj1hwrc532k0nc28gy0"; 69 sha256 = "1h3nnhn45kf4pbcv669ik4faw04j58k8vbj1hwrc532k0nc28gy0";
70 }; 70 };
71 propagatedBuildInputs = with self; [ six paste PasteDeploy argparse ]; 71 propagatedBuildInputs = with self; [ six paste PasteDeploy ];
72 }); 72 });
73 }; 73 };
74 in 74 in
75 python3.override { inherit packageOverrides; }; 75 python36.override { inherit packageOverrides; };
76 pythonEnv = python-pkgs: with python-pkgs; [ 76 pythonEnv = python-pkgs: with python-pkgs; [
77 waitress alembic dateutil wtforms pybcrypt 77 waitress alembic dateutil wtforms pybcrypt
78 pytest pytest_xdist werkzeug celery 78 pytest pytest_xdist werkzeug celery
@@ -80,7 +80,7 @@ let
80 sqlalchemy itsdangerous pytz sphinx six 80 sqlalchemy itsdangerous pytz sphinx six
81 oauthlib unidecode jsonschema PasteDeploy 81 oauthlib unidecode jsonschema PasteDeploy
82 requests PyLD exifread 82 requests PyLD exifread
83 typing pasteScript 83 typing pasteScript lxml
84 # For images plugin 84 # For images plugin
85 pillow 85 pillow
86 # For video plugin 86 # For video plugin