aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/tools/mastodon/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/tools/mastodon/default.nix')
-rw-r--r--nixops/modules/websites/tools/mastodon/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/nixops/modules/websites/tools/mastodon/default.nix b/nixops/modules/websites/tools/mastodon/default.nix
index ebea48f..048d845 100644
--- a/nixops/modules/websites/tools/mastodon/default.nix
+++ b/nixops/modules/websites/tools/mastodon/default.nix
@@ -13,6 +13,7 @@ in {
13 }; 13 };
14 14
15 config = lib.mkIf cfg.enable { 15 config = lib.mkIf cfg.enable {
16 deployment.keys = mastodon.keys;
16 ids.uids.mastodon = myconfig.env.tools.mastodon.user.uid; 17 ids.uids.mastodon = myconfig.env.tools.mastodon.user.uid;
17 ids.gids.mastodon = myconfig.env.tools.mastodon.user.gid; 18 ids.gids.mastodon = myconfig.env.tools.mastodon.user.gid;
18 19
@@ -54,7 +55,7 @@ in {
54 55
55 serviceConfig = { 56 serviceConfig = {
56 User = "mastodon"; 57 User = "mastodon";
57 EnvironmentFile = mastodon.config; 58 EnvironmentFile = "/run/keys/webapps/tools-mastodon";
58 PrivateTmp = true; 59 PrivateTmp = true;
59 Restart = "always"; 60 Restart = "always";
60 TimeoutSec = 15; 61 TimeoutSec = 15;
@@ -87,7 +88,7 @@ in {
87 88
88 serviceConfig = { 89 serviceConfig = {
89 User = "mastodon"; 90 User = "mastodon";
90 EnvironmentFile = mastodon.config; 91 EnvironmentFile = "/run/keys/webapps/tools-mastodon";
91 PrivateTmp = true; 92 PrivateTmp = true;
92 Restart = "always"; 93 Restart = "always";
93 TimeoutSec = 60; 94 TimeoutSec = 60;
@@ -116,7 +117,7 @@ in {
116 117
117 serviceConfig = { 118 serviceConfig = {
118 User = "mastodon"; 119 User = "mastodon";
119 EnvironmentFile = mastodon.config; 120 EnvironmentFile = "/run/keys/webapps/tools-mastodon";
120 PrivateTmp = true; 121 PrivateTmp = true;
121 Restart = "always"; 122 Restart = "always";
122 TimeoutSec = 15; 123 TimeoutSec = 15;