aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/tools/mastodon/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/tools/mastodon/default.nix')
-rw-r--r--nixops/modules/websites/tools/mastodon/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixops/modules/websites/tools/mastodon/default.nix b/nixops/modules/websites/tools/mastodon/default.nix
index 048d845..a3f2364 100644
--- a/nixops/modules/websites/tools/mastodon/default.nix
+++ b/nixops/modules/websites/tools/mastodon/default.nix
@@ -13,7 +13,7 @@ in {
13 }; 13 };
14 14
15 config = lib.mkIf cfg.enable { 15 config = lib.mkIf cfg.enable {
16 deployment.keys = mastodon.keys; 16 mySecrets.keys = mastodon.keys;
17 ids.uids.mastodon = myconfig.env.tools.mastodon.user.uid; 17 ids.uids.mastodon = myconfig.env.tools.mastodon.user.uid;
18 ids.gids.mastodon = myconfig.env.tools.mastodon.user.gid; 18 ids.gids.mastodon = myconfig.env.tools.mastodon.user.gid;
19 19
@@ -55,7 +55,7 @@ in {
55 55
56 serviceConfig = { 56 serviceConfig = {
57 User = "mastodon"; 57 User = "mastodon";
58 EnvironmentFile = "/run/keys/webapps/tools-mastodon"; 58 EnvironmentFile = "/var/secrets/webapps/tools-mastodon";
59 PrivateTmp = true; 59 PrivateTmp = true;
60 Restart = "always"; 60 Restart = "always";
61 TimeoutSec = 15; 61 TimeoutSec = 15;
@@ -88,7 +88,7 @@ in {
88 88
89 serviceConfig = { 89 serviceConfig = {
90 User = "mastodon"; 90 User = "mastodon";
91 EnvironmentFile = "/run/keys/webapps/tools-mastodon"; 91 EnvironmentFile = "/var/secrets/webapps/tools-mastodon";
92 PrivateTmp = true; 92 PrivateTmp = true;
93 Restart = "always"; 93 Restart = "always";
94 TimeoutSec = 60; 94 TimeoutSec = 60;
@@ -117,7 +117,7 @@ in {
117 117
118 serviceConfig = { 118 serviceConfig = {
119 User = "mastodon"; 119 User = "mastodon";
120 EnvironmentFile = "/run/keys/webapps/tools-mastodon"; 120 EnvironmentFile = "/var/secrets/webapps/tools-mastodon";
121 PrivateTmp = true; 121 PrivateTmp = true;
122 Restart = "always"; 122 Restart = "always";
123 TimeoutSec = 15; 123 TimeoutSec = 15;