aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/tools/git/mantisbt/mantisbt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/tools/git/mantisbt/mantisbt.nix')
-rw-r--r--nixops/modules/websites/tools/git/mantisbt/mantisbt.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/nixops/modules/websites/tools/git/mantisbt/mantisbt.nix b/nixops/modules/websites/tools/git/mantisbt/mantisbt.nix
index b564058..41c5e90 100644
--- a/nixops/modules/websites/tools/git/mantisbt/mantisbt.nix
+++ b/nixops/modules/websites/tools/git/mantisbt/mantisbt.nix
@@ -17,8 +17,8 @@ let
17 }); 17 });
18 }; 18 };
19 in rec { 19 in rec {
20 keys."tools-mantisbt" = { 20 keys = [{
21 destDir = "/run/keys/webapps"; 21 dest = "webapps/tools-mantisbt";
22 user = apache.user; 22 user = apache.user;
23 group = apache.group; 23 group = apache.group;
24 permissions = "0400"; 24 permissions = "0400";
@@ -56,7 +56,7 @@ let
56 $g_ldap_realname_field = 'cn'; 56 $g_ldap_realname_field = 'cn';
57 $g_ldap_organization = '(memberOf=cn=users,cn=mantisbt,ou=services,dc=immae,dc=eu)'; 57 $g_ldap_organization = '(memberOf=cn=users,cn=mantisbt,ou=services,dc=immae,dc=eu)';
58 ''; 58 '';
59 }; 59 }];
60 webRoot = stdenv.mkDerivation rec { 60 webRoot = stdenv.mkDerivation rec {
61 name = "mantisbt-${version}"; 61 name = "mantisbt-${version}";
62 version = "2.11.1"; 62 version = "2.11.1";
@@ -72,7 +72,7 @@ let
72 ]; 72 ];
73 installPhase = '' 73 installPhase = ''
74 cp -a . $out 74 cp -a . $out
75 ln -s /run/keys/webapps/tools-mantisbt $out/config/config_inc.php 75 ln -s /var/secrets/webapps/tools-mantisbt $out/config/config_inc.php
76 ln -s ${plugins.slack} $out/plugins/Slack 76 ln -s ${plugins.slack} $out/plugins/Slack
77 ln -s ${plugins.source-integration}/Source* $out/plugins/ 77 ln -s ${plugins.source-integration}/Source* $out/plugins/
78 ''; 78 '';
@@ -102,9 +102,9 @@ let
102 ''; 102 '';
103 }; 103 };
104 phpFpm = rec { 104 phpFpm = rec {
105 serviceDeps = [ "postgresql.service" "openldap.service" "tools-mantisbt-key.service" ]; 105 serviceDeps = [ "postgresql.service" "openldap.service" ];
106 basedir = builtins.concatStringsSep ":" ( 106 basedir = builtins.concatStringsSep ":" (
107 [ webRoot "/run/keys/webapps/tools-mantisbt" ] 107 [ webRoot "/var/secrets/webapps/tools-mantisbt" ]
108 ++ lib.attrsets.mapAttrsToList (name: value: value) plugins); 108 ++ lib.attrsets.mapAttrsToList (name: value: value) plugins);
109 socket = "/var/run/phpfpm/mantisbt.sock"; 109 socket = "/var/run/phpfpm/mantisbt.sock";
110 pool = '' 110 pool = ''