aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/phpfpm/pool-options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/phpfpm/pool-options.nix')
-rw-r--r--nixops/modules/websites/phpfpm/pool-options.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/nixops/modules/websites/phpfpm/pool-options.nix b/nixops/modules/websites/phpfpm/pool-options.nix
deleted file mode 100644
index cc688c2..0000000
--- a/nixops/modules/websites/phpfpm/pool-options.nix
+++ /dev/null
@@ -1,35 +0,0 @@
1{ lib }:
2
3with lib; {
4
5 options = {
6
7 listen = mkOption {
8 type = types.str;
9 example = "/path/to/unix/socket";
10 description = ''
11 The address on which to accept FastCGI requests.
12 '';
13 };
14
15 extraConfig = mkOption {
16 type = types.lines;
17 example = ''
18 user = nobody
19 pm = dynamic
20 pm.max_children = 75
21 pm.start_servers = 10
22 pm.min_spare_servers = 5
23 pm.max_spare_servers = 20
24 pm.max_requests = 500
25 '';
26
27 description = ''
28 Extra lines that go into the pool configuration.
29 See the documentation on <literal>php-fpm.conf</literal> for
30 details on configuration directives.
31 '';
32 };
33 };
34}
35