aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/default.nix')
-rw-r--r--nixops/modules/websites/default.nix85
1 files changed, 2 insertions, 83 deletions
diff --git a/nixops/modules/websites/default.nix b/nixops/modules/websites/default.nix
index 7ed00db..891d917 100644
--- a/nixops/modules/websites/default.nix
+++ b/nixops/modules/websites/default.nix
@@ -305,88 +305,7 @@ in
305 ''; 305 '';
306 }; 306 };
307 apaxy = { 307 apaxy = {
308 extraConfig = '' 308 extraConfig = (pkgs.webapps.apache-theme.override { inherit theme_root; }).apacheConfig;
309 <Macro Apaxy %{folder} %{ignored}>
310 Alias /theme ${theme_root}
311 <Directory ${theme_root}>
312 Options -Indexes
313 AllowOverride None
314 Require all granted
315 </Directory>
316
317 # mod_autoindex
318 <Directory %{folder}>
319 Options Indexes
320 AllowOverride None
321 Require all granted
322
323 # Inspired from Apaxy by @adamwhitcroft
324
325 IndexOptions +Charset=UTF-8 +FancyIndexing +IgnoreCase +FoldersFirst +XHTML +HTMLTable +SuppressRules +SuppressDescription +NameWidth=* +IconsAreLinks +ShowForbidden
326
327 IndexHeadInsert "<meta name=\"viewport\" content=\"width=device-width, initial-scale=1\" />"
328
329 IndexIgnoreReset ON
330 IndexIgnore /theme .htaccess %{ignored}
331
332 AddIcon /theme/icons/blank.png ^^BLANKICON^^
333 AddIcon /theme/icons/folder.png ^^DIRECTORY^^
334 AddIcon /theme/icons/folder-home.png ..
335
336 AddIconByType (TXT,/theme/icons/text.png) text/*
337 AddIconByType (IMG,/theme/icons/image.png) image/*
338 AddIconByType (SND,/theme/icons/audio.png) audio/*
339 AddIconByType (VID,/theme/icons/video.png) video/*
340
341 AddIcon /theme/icons/archive.png .7z .bz2 .cab .gz .tar
342 AddIcon /theme/icons/audio.png .aac .aif .aifc .aiff .ape .au .flac .iff .m4a .mid .mp3 .mpa .ra .wav .wma .f4a .f4b .oga .ogg .xm .it .s3m .mod
343 AddIcon /theme/icons/bin.png .bin .hex
344 AddIcon /theme/icons/bmp.png .bmp
345 AddIcon /theme/icons/c.png .c
346 AddIcon /theme/icons/calc.png .xlsx .xlsm .xltx .xltm .xlam .xlr .xls .csv
347 AddIcon /theme/icons/cd.png .iso
348 AddIcon /theme/icons/cpp.png .cpp
349 AddIcon /theme/icons/css.png .css .sass .scss
350 AddIcon /theme/icons/deb.png .deb
351 AddIcon /theme/icons/doc.png .doc .docx .docm .dot .dotx .dotm .log .msg .odt .pages .rtf .tex .wpd .wps
352 AddIcon /theme/icons/draw.png .svg .svgz
353 AddIcon /theme/icons/eps.png .ai .eps
354 AddIcon /theme/icons/exe.png .exe
355 AddIcon /theme/icons/gif.png .gif
356 AddIcon /theme/icons/h.png .h
357 AddIcon /theme/icons/html.png .html .xhtml .shtml .htm .URL .url
358 AddIcon /theme/icons/ico.png .ico
359 AddIcon /theme/icons/java.png .jar
360 AddIcon /theme/icons/jpg.png .jpg .jpeg .jpe
361 AddIcon /theme/icons/js.png .js .json
362 AddIcon /theme/icons/markdown.png .md
363 AddIcon /theme/icons/package.png .pkg .dmg
364 AddIcon /theme/icons/pdf.png .pdf
365 AddIcon /theme/icons/php.png .php .phtml
366 AddIcon /theme/icons/playlist.png .m3u .m3u8 .pls .pls8
367 AddIcon /theme/icons/png.png .png
368 AddIcon /theme/icons/ps.png .ps
369 AddIcon /theme/icons/psd.png .psd
370 AddIcon /theme/icons/py.png .py
371 AddIcon /theme/icons/rar.png .rar
372 AddIcon /theme/icons/rb.png .rb
373 AddIcon /theme/icons/rpm.png .rpm
374 AddIcon /theme/icons/rss.png .rss
375 AddIcon /theme/icons/script.png .bat .cmd .sh
376 AddIcon /theme/icons/sql.png .sql
377 AddIcon /theme/icons/tiff.png .tiff .tif
378 AddIcon /theme/icons/text.png .txt .nfo
379 AddIcon /theme/icons/video.png .asf .asx .avi .flv .mkv .mov .mp4 .mpg .rm .srt .swf .vob .wmv .m4v .f4v .f4p .ogv
380 AddIcon /theme/icons/xml.png .xml
381 AddIcon /theme/icons/zip.png .zip
382 DefaultIcon /theme/icons/default.png
383
384 HeaderName /theme/header.html
385 ReadmeName /theme/footer.html
386 IndexStyleSheet /theme/style.css
387 </Directory>
388 </Macro>
389 '';
390 }; 309 };
391 http2 = { 310 http2 = {
392 modules = [ "http2" ]; 311 modules = [ "http2" ];
@@ -418,7 +337,7 @@ in
418 in '' 337 in ''
419 mkdir -p $out/webapps 338 mkdir -p $out/webapps
420 ln -s ${../../www} $out/webapps/_www 339 ln -s ${../../www} $out/webapps/_www
421 ln -s ${./apache/theme} $out/webapps/_theme 340 ln -s ${pkgs.webapps.apache-theme.theme} $out/webapps/_theme
422 ln -s ${adminer.webRoot} $out/webapps/${adminer.apache.webappName} 341 ln -s ${adminer.webRoot} $out/webapps/${adminer.apache.webappName}
423 ''; 342 '';
424 343