aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/websites/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/websites/default.nix')
-rw-r--r--nixops/modules/websites/default.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/nixops/modules/websites/default.nix b/nixops/modules/websites/default.nix
index c8f7481..14f2116 100644
--- a/nixops/modules/websites/default.nix
+++ b/nixops/modules/websites/default.nix
@@ -179,10 +179,10 @@ in
179 ]; 179 ];
180 }; 180 };
181 181
182 nixpkgs.config.packageOverrides = oldpkgs: rec { 182 nixpkgs.overlays = [ (self: super: rec {
183 php = php72; 183 php = php72;
184 php72 = (oldpkgs.php72.override { 184 php72 = (super.php72.override {
185 mysql.connector-c = pkgs.mariadb; 185 mysql.connector-c = self.mariadb;
186 config.php.mysqlnd = false; 186 config.php.mysqlnd = false;
187 config.php.mysqli = false; 187 config.php.mysqli = false;
188 }).overrideAttrs(old: rec { 188 }).overrideAttrs(old: rec {
@@ -196,11 +196,11 @@ in
196 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c 196 # ext/mysqli/mysqli.c ext/mysqli/mysqli_prop.c
197 # ''; 197 # '';
198 }); 198 });
199 phpPackages = oldpkgs.php72Packages.override { inherit php; }; 199 phpPackages = super.php72Packages.override { inherit php; };
200 composerEnv = import ./commons/composer-env.nix { 200 composerEnv = import ./commons/composer-env.nix {
201 inherit (pkgs) stdenv writeTextFile fetchurl php unzip; 201 inherit (self) stdenv writeTextFile fetchurl php unzip;
202 }; 202 };
203 }; 203 }) ];
204 204
205 services.myWebsites.tools.databases.enable = true; 205 services.myWebsites.tools.databases.enable = true;
206 services.myWebsites.tools.tools.enable = true; 206 services.myWebsites.tools.tools.enable = true;