aboutsummaryrefslogtreecommitdiff
path: root/nixops/modules/dns/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixops/modules/dns/default.nix')
-rw-r--r--nixops/modules/dns/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixops/modules/dns/default.nix b/nixops/modules/dns/default.nix
index 7937714..34019d1 100644
--- a/nixops/modules/dns/default.nix
+++ b/nixops/modules/dns/default.nix
@@ -68,8 +68,8 @@
68 server-id none; 68 server-id none;
69 ''; 69 '';
70 zones = with myconfig.env.dns; 70 zones = with myconfig.env.dns;
71 assert (builtins.substring ((builtins.stringLength soa.email)-1) 1 soa.email) == "."; 71 assert (builtins.substring ((builtins.stringLength soa.email)-1) 1 soa.email) != ".";
72 assert (builtins.substring ((builtins.stringLength soa.primary)-1) 1 soa.primary) == "."; 72 assert (builtins.substring ((builtins.stringLength soa.primary)-1) 1 soa.primary) != ".";
73 (map (conf: { 73 (map (conf: {
74 name = conf.name; 74 name = conf.name;
75 master = false; 75 master = false;
@@ -87,7 +87,7 @@
87 else []; 87 else [];
88 file = pkgs.writeText "${conf.name}.zone" '' 88 file = pkgs.writeText "${conf.name}.zone" ''
89 $TTL 10800 89 $TTL 10800
90 @ IN SOA ${soa.primary} ${soa.email} ${soa.serial} ${soa.refresh} ${soa.retry} ${soa.expire} ${soa.ttl} 90 @ IN SOA ${soa.primary}. ${builtins.replaceStrings ["@"] ["."] soa.email}. ${soa.serial} ${soa.refresh} ${soa.retry} ${soa.expire} ${soa.ttl}
91 91
92 ${lib.concatStringsSep "\n" (map (x: "@ IN NS ${x}.") (lib.concatMap (n: lib.attrsets.mapAttrsToList (k: v: k) ns.${n}) conf.ns))} 92 ${lib.concatStringsSep "\n" (map (x: "@ IN NS ${x}.") (lib.concatMap (n: lib.attrsets.mapAttrsToList (k: v: k) ns.${n}) conf.ns))}
93 93