aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/tools/tools/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/tools/tools/default.nix')
-rw-r--r--modules/private/websites/tools/tools/default.nix28
1 files changed, 15 insertions, 13 deletions
diff --git a/modules/private/websites/tools/tools/default.nix b/modules/private/websites/tools/tools/default.nix
index 6464206..ac92ef4 100644
--- a/modules/private/websites/tools/tools/default.nix
+++ b/modules/private/websites/tools/tools/default.nix
@@ -1,5 +1,7 @@
1{ lib, pkgs, config, ... }: 1{ lib, pkgs, config, ... }:
2let 2let
3 flakeCompat = import ../../../../../lib/flake-compat.nix;
4
3 adminer = pkgs.callPackage ./adminer.nix { 5 adminer = pkgs.callPackage ./adminer.nix {
4 inherit (pkgs.webapps) adminer; 6 inherit (pkgs.webapps) adminer;
5 }; 7 };
@@ -64,6 +66,9 @@ let
64 cfg = config.myServices.websites.tools.tools; 66 cfg = config.myServices.websites.tools.tools;
65 pcfg = config.services.phpfpm.pools; 67 pcfg = config.services.phpfpm.pools;
66in { 68in {
69 imports =
70 builtins.attrValues (flakeCompat ../../../../../flakes/private/paste).nixosModules;
71
67 options.myServices.websites.tools.tools = { 72 options.myServices.websites.tools.tools = {
68 enable = lib.mkEnableOption "enable tools website"; 73 enable = lib.mkEnableOption "enable tools website";
69 }; 74 };
@@ -165,13 +170,16 @@ in {
165 (phpbb.apache.vhostConf pcfg.phpbb.socket) 170 (phpbb.apache.vhostConf pcfg.phpbb.socket)
166 (dmarc-reports.apache.vhostConf pcfg.dmarc-reports.socket) 171 (dmarc-reports.apache.vhostConf pcfg.dmarc-reports.socket)
167 '' 172 ''
168 Alias /paste /var/lib/fiche 173 <Location "/paste/">
169 <Directory "/var/lib/fiche"> 174 ProxyPass unix://${config.services.paste.sockets.gunicorn}|http://tools.immae.eu/paste/
170 DirectoryIndex index.txt index.html 175 ProxyPassReverse unix://${config.services.paste.sockets.gunicorn}|http://tools.immae.eu/paste/
171 AllowOverride None 176 ProxyPreserveHost on
172 Require all granted 177 </Location>
173 Options -Indexes 178 <Location "/paste">
174 </Directory> 179 ProxyPass unix://${config.services.paste.sockets.gunicorn}|http://tools.immae.eu/paste/
180 ProxyPassReverse unix://${config.services.paste.sockets.gunicorn}|http://tools.immae.eu/paste/
181 ProxyPreserveHost on
182 </Location>
175 183
176 Alias /BIP39 /var/lib/buildbot/outputs/immae/bip39 184 Alias /BIP39 /var/lib/buildbot/outputs/immae/bip39
177 <Directory "/var/lib/buildbot/outputs/immae/bip39"> 185 <Directory "/var/lib/buildbot/outputs/immae/bip39">
@@ -437,12 +445,6 @@ in {
437 paths = [ "/var/secrets/webapps/tools-wallabag" ]; 445 paths = [ "/var/secrets/webapps/tools-wallabag" ];
438 }; 446 };
439 447
440 services.fiche = {
441 enable = true;
442 port = config.myEnv.ports.fiche;
443 domain = "tools.immae.eu/paste";
444 https = true;
445 };
446 }; 448 };
447} 449}
448 450