aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/tools/mastodon/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/tools/mastodon/default.nix')
-rw-r--r--modules/private/websites/tools/mastodon/default.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/modules/private/websites/tools/mastodon/default.nix b/modules/private/websites/tools/mastodon/default.nix
index 87e8d72..3512cf1 100644
--- a/modules/private/websites/tools/mastodon/default.nix
+++ b/modules/private/websites/tools/mastodon/default.nix
@@ -1,7 +1,7 @@
1{ lib, pkgs, config, ... }: 1{ lib, pkgs, config, ... }:
2let 2let
3 env = config.myEnv.tools.mastodon; 3 env = config.myEnv.tools.mastodon;
4 root = "/run/current-system/webapps/tools_mastodon"; 4 root = "${mcfg.workdir}/public/";
5 cfg = config.myServices.websites.tools.mastodon; 5 cfg = config.myServices.websites.tools.mastodon;
6 mcfg = config.services.mastodon; 6 mcfg = config.services.mastodon;
7in { 7in {
@@ -82,10 +82,6 @@ in {
82 services.websites.env.tools.modules = [ 82 services.websites.env.tools.modules = [
83 "headers" "proxy" "proxy_wstunnel" "proxy_http" 83 "headers" "proxy" "proxy_wstunnel" "proxy_http"
84 ]; 84 ];
85 system.extraSystemBuilderCmds = ''
86 mkdir -p $out/webapps
87 ln -s ${mcfg.workdir}/public/ $out/webapps/tools_mastodon
88 '';
89 services.websites.env.tools.vhostConfs.mastodon = { 85 services.websites.env.tools.vhostConfs.mastodon = {
90 certName = "eldiron"; 86 certName = "eldiron";
91 addToCerts = true; 87 addToCerts = true;