aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/ressourcerie_banon/cloud.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/ressourcerie_banon/cloud.nix')
-rw-r--r--modules/private/websites/ressourcerie_banon/cloud.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/modules/private/websites/ressourcerie_banon/cloud.nix b/modules/private/websites/ressourcerie_banon/cloud.nix
new file mode 100644
index 0000000..5179218
--- /dev/null
+++ b/modules/private/websites/ressourcerie_banon/cloud.nix
@@ -0,0 +1,20 @@
1{ lib, pkgs, config, ... }:
2let
3 cfg = config.myServices.websites.ressourcerie_banon.cloud;
4 nextcloud = config.myServices.tools.cloud.farm.package;
5in {
6 options.myServices.websites.ressourcerie_banon.cloud.enable = lib.mkEnableOption "enable Ressourcerie Banon’s cloud";
7
8 config = lib.mkIf cfg.enable {
9 myServices.tools.cloud.farm.instances = [ "ressourcerie_banon" ];
10 services.websites.env.production.modules = [ "proxy_fcgi" ];
11 services.websites.env.production.vhostConfs.ressourcerie_banon_cloud = {
12 certName = "ressourcerie_banon";
13 addToCerts = true;
14 hosts = ["cloud.le-garage-autonome.org"];
15 root = nextcloud;
16 extraConfig = [ config.myServices.tools.cloud.farm.vhosts.ressourcerie_banon ];
17 };
18 };
19}
20