aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/piedsjaloux/production.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/piedsjaloux/production.nix')
-rw-r--r--modules/private/websites/piedsjaloux/production.nix49
1 files changed, 23 insertions, 26 deletions
diff --git a/modules/private/websites/piedsjaloux/production.nix b/modules/private/websites/piedsjaloux/production.nix
index e12b046..fed5a0f 100644
--- a/modules/private/websites/piedsjaloux/production.nix
+++ b/modules/private/websites/piedsjaloux/production.nix
@@ -55,32 +55,29 @@ in {
55 phpPackage = pkgs.php72; 55 phpPackage = pkgs.php72;
56 }; 56 };
57 57
58 secrets.keys = [ 58 secrets.keys."websites/piedsjaloux/production" = {
59 { 59 user = config.services.httpd.Prod.user;
60 dest = "websites/piedsjaloux/production"; 60 group = config.services.httpd.Prod.group;
61 user = config.services.httpd.Prod.user; 61 permissions = "0400";
62 group = config.services.httpd.Prod.group; 62 text = ''
63 permissions = "0400"; 63 # This file is auto-generated during the composer install
64 text = '' 64 parameters:
65 # This file is auto-generated during the composer install 65 database_host: ${secrets.mysql.host}
66 parameters: 66 database_port: ${secrets.mysql.port}
67 database_host: ${secrets.mysql.host} 67 database_name: ${secrets.mysql.database}
68 database_port: ${secrets.mysql.port} 68 database_user: ${secrets.mysql.user}
69 database_name: ${secrets.mysql.database} 69 database_password: ${secrets.mysql.password}
70 database_user: ${secrets.mysql.user} 70 database_server_version: ${pkgs.mariadb.mysqlVersion}
71 database_password: ${secrets.mysql.password} 71 mailer_transport: smtp
72 database_server_version: ${pkgs.mariadb.mysqlVersion} 72 mailer_host: 127.0.0.1
73 mailer_transport: smtp 73 mailer_user: null
74 mailer_host: 127.0.0.1 74 mailer_password: null
75 mailer_user: null 75 secret: ${secrets.secret}
76 mailer_password: null 76 pdflatex: "${texlive}/bin/pdflatex"
77 secret: ${secrets.secret} 77 leapt_im:
78 pdflatex: "${texlive}/bin/pdflatex" 78 binary_path: ${pkgs.imagemagick}/bin
79 leapt_im: 79 '';
80 binary_path: ${pkgs.imagemagick}/bin 80 };
81 '';
82 }
83 ];
84 81
85 services.websites.env.production.vhostConfs.piedsjaloux_production = { 82 services.websites.env.production.vhostConfs.piedsjaloux_production = {
86 certName = "piedsjaloux"; 83 certName = "piedsjaloux";