aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/leila/production.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/leila/production.nix')
-rw-r--r--modules/private/websites/leila/production.nix27
1 files changed, 13 insertions, 14 deletions
diff --git a/modules/private/websites/leila/production.nix b/modules/private/websites/leila/production.nix
index e8591c8..3b289cf 100644
--- a/modules/private/websites/leila/production.nix
+++ b/modules/private/websites/leila/production.nix
@@ -7,19 +7,18 @@ in {
7 7
8 config = lib.mkIf cfg.enable { 8 config = lib.mkIf cfg.enable {
9 services.phpfpm.pools.leila = { 9 services.phpfpm.pools.leila = {
10 listen = "/run/phpfpm/leila.sock"; 10 user = "wwwrun";
11 extraConfig = '' 11 group = "wwwrun";
12 user = wwwrun 12 settings = {
13 group = wwwrun 13 "listen.owner" = "wwwrun";
14 listen.owner = wwwrun 14 "listen.group" = "wwwrun";
15 listen.group = wwwrun
16 15
17 pm = ondemand 16 "pm" = "ondemand";
18 pm.max_children = 5 17 "pm.max_children" = "5";
19 pm.process_idle_timeout = 60 18 "pm.process_idle_timeout" = "60";
20 19
21 php_admin_value[open_basedir] = "${varDir}:/tmp" 20 "php_admin_value[open_basedir]" = "${varDir}:/tmp";
22 ''; 21 };
23 }; 22 };
24 23
25 services.webstats.sites = [ 24 services.webstats.sites = [
@@ -46,7 +45,7 @@ in {
46 Require ldap-group cn=chorale.leila.bouya.org,cn=httpd,ou=services,dc=immae,dc=eu 45 Require ldap-group cn=chorale.leila.bouya.org,cn=httpd,ou=services,dc=immae,dc=eu
47 46
48 <FilesMatch "\.php$"> 47 <FilesMatch "\.php$">
49 SetHandler "proxy:unix:/run/phpfpm/leila.sock|fcgi://localhost" 48 SetHandler "proxy:unix:${config.services.phpfpm.pools.leila.socket}|fcgi://localhost"
50 </FilesMatch> 49 </FilesMatch>
51 </Directory> 50 </Directory>
52 '' 51 ''
@@ -66,7 +65,7 @@ in {
66 AllowOverride None 65 AllowOverride None
67 66
68 <FilesMatch "\.php$"> 67 <FilesMatch "\.php$">
69 SetHandler "proxy:unix:/run/phpfpm/leila.sock|fcgi://localhost" 68 SetHandler "proxy:unix:${config.services.phpfpm.pools.leila.socket}|fcgi://localhost"
70 </FilesMatch> 69 </FilesMatch>
71 </Directory> 70 </Directory>
72 '' 71 ''
@@ -89,7 +88,7 @@ in {
89 Require ldap-group cn=chorale.leila.bouya.org,cn=httpd,ou=services,dc=immae,dc=eu 88 Require ldap-group cn=chorale.leila.bouya.org,cn=httpd,ou=services,dc=immae,dc=eu
90 89
91 <FilesMatch "\.php$"> 90 <FilesMatch "\.php$">
92 SetHandler "proxy:unix:/run/phpfpm/leila.sock|fcgi://localhost" 91 SetHandler "proxy:unix:${config.services.phpfpm.pools.leila.socket}|fcgi://localhost"
93 </FilesMatch> 92 </FilesMatch>
94 </Directory> 93 </Directory>
95 <Directory ${varDir}> 94 <Directory ${varDir}>