aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/florian/integration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/florian/integration.nix')
-rw-r--r--modules/private/websites/florian/integration.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/modules/private/websites/florian/integration.nix b/modules/private/websites/florian/integration.nix
deleted file mode 100644
index 8ac1f46..0000000
--- a/modules/private/websites/florian/integration.nix
+++ /dev/null
@@ -1,34 +0,0 @@
1{ lib, pkgs, config, ... }:
2let
3 adminer = pkgs.callPackage ../commons/adminer.nix { inherit config; };
4 cfg = config.myServices.websites.florian.integration;
5 varDir = "/var/lib/ftp/florian/www.ft.immae.dev";
6 env = config.myEnv.websites.florian;
7in {
8 options.myServices.websites.florian.integration.enable = lib.mkEnableOption "enable Florian's website integration";
9
10 config = lib.mkIf cfg.enable {
11 security.acme.certs."ftp".extraDomains."ft.immae.dev" = null;
12
13 services.websites.env.integration.modules = adminer.apache.modules;
14 services.websites.env.integration.vhostConfs.florian_integration = {
15 certName = "integration";
16 addToCerts = true;
17 hosts = [ "www.ft.immae.dev" ];
18 root = varDir;
19 extraConfig = [
20 (adminer.apache.vhostConf null)
21 ''
22 ServerAdmin ${env.server_admin}
23
24 <Directory ${varDir}>
25 DirectoryIndex index.php index.htm index.html
26 Options Indexes FollowSymLinks MultiViews Includes
27 AllowOverride None
28 Require all granted
29 </Directory>
30 ''
31 ];
32 };
33 };
34}