aboutsummaryrefslogtreecommitdiff
path: root/modules/private/websites/chloe/integration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/websites/chloe/integration.nix')
-rw-r--r--modules/private/websites/chloe/integration.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/modules/private/websites/chloe/integration.nix b/modules/private/websites/chloe/integration.nix
index c4b79f8..7ed3852 100644
--- a/modules/private/websites/chloe/integration.nix
+++ b/modules/private/websites/chloe/integration.nix
@@ -9,7 +9,6 @@ let
9 varDir = "/var/lib/chloe_integration"; 9 varDir = "/var/lib/chloe_integration";
10 }; 10 };
11 cfg = config.myServices.websites.chloe.integration; 11 cfg = config.myServices.websites.chloe.integration;
12 webappdir = config.services.websites.webappDirsPaths.chloe_integration;
13in { 12in {
14 options.myServices.websites.chloe.integration.enable = lib.mkEnableOption "enable Chloe's website in integration"; 13 options.myServices.websites.chloe.integration.enable = lib.mkEnableOption "enable Chloe's website in integration";
15 14
@@ -61,13 +60,12 @@ in {
61 install -m 0750 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir}/phpSessions 60 install -m 0750 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir}/phpSessions
62 ''; 61 '';
63 }; 62 };
64 services.websites.webappDirs.chloe_integration = app.webRoot;
65 services.websites.env.integration.modules = [ "proxy_fcgi" ]; 63 services.websites.env.integration.modules = [ "proxy_fcgi" ];
66 services.websites.env.integration.vhostConfs.chloe_integration = { 64 services.websites.env.integration.vhostConfs.chloe_integration = {
67 certName = "integration"; 65 certName = "integration";
68 addToCerts = true; 66 addToCerts = true;
69 hosts = ["chloe.immae.eu" ]; 67 hosts = ["chloe.immae.eu" ];
70 root = webappdir; 68 root = app.webRoot;
71 extraConfig = [ 69 extraConfig = [
72 '' 70 ''
73 Include ${config.secrets.fullPaths."websites/chloe/integration"} 71 Include ${config.secrets.fullPaths."websites/chloe/integration"}
@@ -78,16 +76,16 @@ in {
78 SetHandler "proxy:unix:${config.services.phpfpm.pools.chloe_integration.socket}|fcgi://localhost" 76 SetHandler "proxy:unix:${config.services.phpfpm.pools.chloe_integration.socket}|fcgi://localhost"
79 </FilesMatch> 77 </FilesMatch>
80 78
81 <Directory ${webappdir}> 79 <Directory ${app.webRoot}>
82 DirectoryIndex index.php index.htm index.html 80 DirectoryIndex index.php index.htm index.html
83 Options -Indexes +FollowSymLinks +MultiViews +Includes 81 Options -Indexes +FollowSymLinks +MultiViews +Includes
84 Include ${webappdir}/htaccess.txt 82 Include ${app.webRoot}/htaccess.txt
85 83
86 AllowOverride AuthConfig FileInfo Limit 84 AllowOverride AuthConfig FileInfo Limit
87 Require all granted 85 Require all granted
88 </Directory> 86 </Directory>
89 87
90 <DirectoryMatch "${webappdir}/squelettes"> 88 <DirectoryMatch "${app.webRoot}/squelettes">
91 Require all denied 89 Require all denied
92 </DirectoryMatch> 90 </DirectoryMatch>
93 91