aboutsummaryrefslogtreecommitdiff
path: root/modules/private/system/eldiron.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/system/eldiron.nix')
-rw-r--r--modules/private/system/eldiron.nix26
1 files changed, 24 insertions, 2 deletions
diff --git a/modules/private/system/eldiron.nix b/modules/private/system/eldiron.nix
index 102a517..2475710 100644
--- a/modules/private/system/eldiron.nix
+++ b/modules/private/system/eldiron.nix
@@ -31,12 +31,34 @@
31 myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; }; 31 myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
32 32
33 fileSystems = { 33 fileSystems = {
34 # pools:
35 # zpool: ashift=12
36 # zfast: ashift=12
37 # zfs:
38 # zpool/: acltype=posixacl ; xattr=sa ; atime=off ; mountpoint=legacy
39 # zpool/root: encryption=on ; keyformat=passphrase ; keylocation=file:///boot/pass.key
40 # zpool/root/var: atime=on
41 # zfast/: acltype=posixacl ; xattr=sa ; atime=off ; mountpoint=legacy
42 # zfast/root: encryption=on ; keyformat=passphrase ; keylocation=file:///boot/pass.key
43 # zfast/root/etc: ø
44 # zfast/root/nix: ø
45 # zfast/root/tmp: async=disabled
46 # zfast/root/var: atime=on
47 # zfast/root/var/lib: ø
48 # zfast/root/var/lib/mysql: logbias=throughput ; atime=off ; primarycache=metadata
49 # zfast/root/var/lib/postgresql: recordsize=8K ; atime=off ; logbias=throughput
50 # zfast/root/var/lib/postgresql/11.0: ø
51 # zfast/root/var/lib/postgresql/11.0/pg_wal: ø
34 "/" = { fsType = "zfs"; device = "zpool/root"; }; 52 "/" = { fsType = "zfs"; device = "zpool/root"; };
35 "/boot" = { fsType = "ext4"; device = "/dev/disk/by-uuid/e6bb18fb-ff56-4b5f-ae9f-e60d40dc0622"; }; 53 "/boot" = { fsType = "ext4"; device = "/dev/disk/by-uuid/e6bb18fb-ff56-4b5f-ae9f-e60d40dc0622"; };
36 "/etc" = { fsType = "zfs"; device = "zpool/root/etc"; }; 54 "/etc" = { fsType = "zfs"; device = "zpool/root/etc"; };
37 "/nix" = { fsType = "zfs"; device = "zpool/root/nix"; }; 55 "/nix" = { fsType = "zfs"; device = "zfast/root/nix"; };
38 "/tmp" = { fsType = "zfs"; device = "zpool/root/tmp"; }; 56 "/tmp" = { fsType = "zfs"; device = "zfast/root/tmp"; };
39 "/var" = { fsType = "zfs"; device = "zpool/root/var"; }; 57 "/var" = { fsType = "zfs"; device = "zpool/root/var"; };
58 "/var/lib/mysql" = { fsType = "zfs"; device = "zfast/root/var/lib/mysql"; };
59 "/var/lib/postgresql" = { fsType = "zfs"; device = "zfast/root/var/lib/postgresql"; };
60 "/var/lib/postgresql/11.0" = { fsType = "zfs"; device = "zfast/root/var/lib/postgresql/11.0"; };
61 "/var/lib/postgresql/11.0/pg_wal" = { fsType = "zfs"; device = "zfast/root/var/lib/postgresql/11.0/pg_wal"; };
40 }; 62 };
41 swapDevices = [ { label = "swap1"; } { label = "swap2"; } ]; 63 swapDevices = [ { label = "swap1"; } { label = "swap2"; } ];
42 hardware.enableRedistributableFirmware = true; 64 hardware.enableRedistributableFirmware = true;