aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index 3b51f37..2cecc6d 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -536,6 +536,16 @@ in
536 }; 536 };
537 }; 537 };
538 }; 538 };
539 vpn = mkOption {
540 description = "VPN configuration";
541 type = attrsOf (submodule {
542 options = {
543 prefix = mkOption { type = str; description = "ipv6 prefix for the vpn subnet"; };
544 privateKey = mkOption { type = str; description = "Private key for the host"; };
545 publicKey = mkOption { type = str; description = "Public key for the host"; };
546 };
547 });
548 };
539 mail = mkOption { 549 mail = mkOption {
540 description = "Mail configuration"; 550 description = "Mail configuration";
541 type = submodule { 551 type = submodule {