aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index 980b878..719bf8f 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -1193,6 +1193,16 @@ in
1193 }; 1193 };
1194 }; 1194 };
1195 }; 1195 };
1196 umami = mkOption {
1197 description = "Umami configuration";
1198 type = submodule {
1199 options = {
1200 listenPort = mkOption { type = port; description = "Port to listen to"; };
1201 postgresql = mkPsqlOptions "Umami";
1202 hashSalt = mkOption { type = str; description = "Hash salt"; };
1203 };
1204 };
1205 };
1196 yourls = mkOption { 1206 yourls = mkOption {
1197 description = "Yourls configuration"; 1207 description = "Yourls configuration";
1198 type = submodule { 1208 type = submodule {