aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index 32af339..980b878 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -1165,6 +1165,16 @@ in
1165 }; 1165 };
1166 }; 1166 };
1167 }; 1167 };
1168 cryptpad = mkOption {
1169 description = "Cryptpad configuration";
1170 type = attrsOf (submodule {
1171 options = {
1172 email = mkOption { type = str; description = "Admin e-mail"; };
1173 admins = mkOption { type = listOf str; description = "Instance admin public keys"; };
1174 port = mkOption { type = port; description = "Port to listen to"; };
1175 };
1176 });
1177 };
1168 ympd = mkOption { 1178 ympd = mkOption {
1169 description = "Ympd configuration"; 1179 description = "Ympd configuration";
1170 type = submodule { 1180 type = submodule {