aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index e79feec..490a405 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -558,6 +558,14 @@ in
558 }; 558 };
559 }; 559 };
560 }; 560 };
561 eban = mkOption {
562 description = "Eban credentials for webhook";
563 type = submodule {
564 options = {
565 password = mkOption { type = str; description = "Password"; };
566 };
567 };
568 };
561 nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; }; 569 nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
562 slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; }; 570 slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
563 slack_channel = mkOption { type = str; description = "Slack channel to push status update"; }; 571 slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };