aboutsummaryrefslogtreecommitdiff
path: root/modules/private/environment.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/environment.nix')
-rw-r--r--modules/private/environment.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/modules/private/environment.nix b/modules/private/environment.nix
index 719bf8f..f0af572 100644
--- a/modules/private/environment.nix
+++ b/modules/private/environment.nix
@@ -228,6 +228,7 @@ in
228 ''; 228 '';
229 type = submodule { 229 type = submodule {
230 options = { 230 options = {
231 rootKeys = mkOption { type = attrsOf str; description = "Keys of root users"; };
231 ldap = mkOption { 232 ldap = mkOption {
232 description = '' 233 description = ''
233 LDAP credentials for cn=ssh,ou=services,dc=immae,dc=eu dn 234 LDAP credentials for cn=ssh,ou=services,dc=immae,dc=eu dn
@@ -804,6 +805,7 @@ in
804 description = "Buildbot configuration"; 805 description = "Buildbot configuration";
805 type = submodule { 806 type = submodule {
806 options = { 807 options = {
808 workerPassword = mkOption { description = "Buildbot worker password"; type = str; };
807 user = mkOption { 809 user = mkOption {
808 description = "Buildbot user"; 810 description = "Buildbot user";
809 type = submodule { 811 type = submodule {
@@ -855,6 +857,7 @@ in
855 ''; 857 '';
856 }; 858 };
857 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; }; 859 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
860 workerPort = mkOption { type = port; description = "Port for the worker"; };
858 secrets = mkOption { 861 secrets = mkOption {
859 type = attrsOf str; 862 type = attrsOf str;
860 description = "Secrets for the project to dump as files"; 863 description = "Secrets for the project to dump as files";