aboutsummaryrefslogtreecommitdiff
path: root/modules/private/databases/redis.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/databases/redis.nix')
-rw-r--r--modules/private/databases/redis.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/private/databases/redis.nix b/modules/private/databases/redis.nix
index bc6460f..5c5b8b0 100644
--- a/modules/private/databases/redis.nix
+++ b/modules/private/databases/redis.nix
@@ -49,7 +49,7 @@ in {
49 decrypt = true; 49 decrypt = true;
50 source = "0.0.0.0:16379"; 50 source = "0.0.0.0:16379";
51 target = "/run/redis/redis.sock"; 51 target = "/run/redis/redis.sock";
52 keyfile = "${config.secrets.location}/redis/spiped_keyfile"; 52 keyfile = config.secrets.fullPaths."redis/spiped_keyfile";
53 }; 53 };
54 }; 54 };
55 systemd.services.spiped_redis = { 55 systemd.services.spiped_redis = {
@@ -70,7 +70,7 @@ in {
70 70
71 services.filesWatcher.predixy = { 71 services.filesWatcher.predixy = {
72 restart = true; 72 restart = true;
73 paths = [ "${config.secrets.location}/redis/predixy.conf" ]; 73 paths = [ config.secrets.fullPaths."redis/predixy.conf" ];
74 }; 74 };
75 75
76 networking.firewall.allowedTCPPorts = [ 7617 16379 ]; 76 networking.firewall.allowedTCPPorts = [ 7617 16379 ];
@@ -126,7 +126,7 @@ in {
126 SupplementaryGroups = "keys"; 126 SupplementaryGroups = "keys";
127 Type = "simple"; 127 Type = "simple";
128 128
129 ExecStart = "${pkgs.predixy}/bin/predixy ${config.secrets.location}/redis/predixy.conf"; 129 ExecStart = "${pkgs.predixy}/bin/predixy ${config.secrets.fullPaths."redis/predixy.conf"}";
130 }; 130 };
131 131
132 }; 132 };