aboutsummaryrefslogtreecommitdiff
path: root/modules/private/databases/redis.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/private/databases/redis.nix')
-rw-r--r--modules/private/databases/redis.nix11
1 files changed, 0 insertions, 11 deletions
diff --git a/modules/private/databases/redis.nix b/modules/private/databases/redis.nix
index 4b26283..4602510 100644
--- a/modules/private/databases/redis.nix
+++ b/modules/private/databases/redis.nix
@@ -17,16 +17,6 @@ in {
17 ''; 17 '';
18 }; 18 };
19 # Output variables 19 # Output variables
20 systemdRuntimeDirectory = lib.mkOption {
21 type = lib.types.str;
22 # Use ReadWritePaths= instead if socketsDir is outside of /run
23 default = assert lib.strings.hasPrefix "/run/" cfg.socketsDir;
24 lib.strings.removePrefix "/run/" cfg.socketsDir;
25 description = ''
26 Adjusted redis sockets directory for systemd
27 '';
28 readOnly = true;
29 };
30 sockets = lib.mkOption { 20 sockets = lib.mkOption {
31 type = lib.types.attrsOf lib.types.path; 21 type = lib.types.attrsOf lib.types.path;
32 default = { 22 default = {
@@ -51,7 +41,6 @@ in {
51 maxclients 1024 41 maxclients 1024
52 ''; 42 '';
53 }; 43 };
54 systemd.services.redis.serviceConfig.RuntimeDirectory = cfg.systemdRuntimeDirectory;
55 44
56 services.spiped = { 45 services.spiped = {
57 enable = true; 46 enable = true;