aboutsummaryrefslogtreecommitdiff
path: root/flakes/private/system/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/private/system/flake.nix')
-rw-r--r--flakes/private/system/flake.nix12
1 files changed, 1 insertions, 11 deletions
diff --git a/flakes/private/system/flake.nix b/flakes/private/system/flake.nix
index 04ebbc7..e40328f 100644
--- a/flakes/private/system/flake.nix
+++ b/flakes/private/system/flake.nix
@@ -54,17 +54,7 @@
54 ''; 54 '';
55 55
56 users.groups.acme.gid = myuids.lib.gids.acme; 56 users.groups.acme.gid = myuids.lib.gids.acme;
57 users.users = 57 users.users.acme.uid = myuids.lib.uids.acme;
58 builtins.listToAttrs (map (x: lib.attrsets.nameValuePair x.name ({
59 isNormalUser = true;
60 home = "/home/${x.name}";
61 createHome = true;
62 linger = true;
63 # Enable in latest unstable homeMode = "755";
64 } // x)) (config.hostEnv.users pkgs))
65 // {
66 acme.uid = myuids.lib.uids.acme;
67 };
68 environment.systemPackages = [ 58 environment.systemPackages = [
69 pkgs.inetutils 59 pkgs.inetutils
70 pkgs.htop 60 pkgs.htop