aboutsummaryrefslogtreecommitdiff
path: root/flakes/private/paste/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/private/paste/flake.nix')
-rw-r--r--flakes/private/paste/flake.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/flakes/private/paste/flake.nix b/flakes/private/paste/flake.nix
new file mode 100644
index 0000000..71314e8
--- /dev/null
+++ b/flakes/private/paste/flake.nix
@@ -0,0 +1,23 @@
1{
2 inputs.paste = {
3 path = "../../paste";
4 type = "path";
5 };
6 inputs.nix-lib.url = "github:NixOS/nixpkgs";
7
8 description = "Private configuration for paste";
9 outputs = { self, nix-lib, paste }:
10 let
11 cfg = name': { config, lib, pkgs, name, ... }: {
12 config = lib.mkIf (name == name') {
13 services.paste = {
14 enable = true;
15 webDirectory = "/paste";
16 };
17 };
18 };
19 in
20 paste.outputs //
21 { nixosModules = paste.nixosModules or {} // nix-lib.lib.genAttrs ["eldiron"] cfg; };
22}
23