aboutsummaryrefslogtreecommitdiff
path: root/flakes/private/paste/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/private/paste/flake.nix')
-rw-r--r--flakes/private/paste/flake.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/flakes/private/paste/flake.nix b/flakes/private/paste/flake.nix
index 71314e8..23f8cd3 100644
--- a/flakes/private/paste/flake.nix
+++ b/flakes/private/paste/flake.nix
@@ -3,12 +3,19 @@
3 path = "../../paste"; 3 path = "../../paste";
4 type = "path"; 4 type = "path";
5 }; 5 };
6 inputs.my-lib = {
7 path = "../../lib";
8 type = "path";
9 };
6 inputs.nix-lib.url = "github:NixOS/nixpkgs"; 10 inputs.nix-lib.url = "github:NixOS/nixpkgs";
7 11
8 description = "Private configuration for paste"; 12 description = "Private configuration for paste";
9 outputs = { self, nix-lib, paste }: 13 outputs = { self, my-lib, nix-lib, paste }:
10 let 14 let
11 cfg = name': { config, lib, pkgs, name, ... }: { 15 cfg = name': { config, lib, pkgs, name, ... }: {
16 imports = [
17 (my-lib.lib.withNarKey paste "nixosModule")
18 ];
12 config = lib.mkIf (name == name') { 19 config = lib.mkIf (name == name') {
13 services.paste = { 20 services.paste = {
14 enable = true; 21 enable = true;