aboutsummaryrefslogtreecommitdiff
path: root/flakes/private/opendmarc/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/private/opendmarc/flake.nix')
-rw-r--r--flakes/private/opendmarc/flake.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/flakes/private/opendmarc/flake.nix b/flakes/private/opendmarc/flake.nix
index debcfbd..2b73070 100644
--- a/flakes/private/opendmarc/flake.nix
+++ b/flakes/private/opendmarc/flake.nix
@@ -3,6 +3,10 @@
3 path = "../../opendmarc"; 3 path = "../../opendmarc";
4 type = "path"; 4 type = "path";
5 }; 5 };
6 inputs.secrets = {
7 path = "../../secrets";
8 type = "path";
9 };
6 inputs.files-watcher = { 10 inputs.files-watcher = {
7 path = "../../files-watcher"; 11 path = "../../files-watcher";
8 type = "path"; 12 type = "path";
@@ -14,14 +18,13 @@
14 inputs.nix-lib.url = "github:NixOS/nixpkgs"; 18 inputs.nix-lib.url = "github:NixOS/nixpkgs";
15 19
16 description = "Private configuration for opendmarc"; 20 description = "Private configuration for opendmarc";
17 outputs = { self, nix-lib, opendmarc, my-lib, files-watcher }: 21 outputs = { self, nix-lib, opendmarc, my-lib, files-watcher, secrets }:
18 let 22 let
19 cfg = name': { config, lib, pkgs, name, ... }: { 23 cfg = name': { config, lib, pkgs, name, ... }: {
20 imports = [ 24 imports = [
21 (my-lib.lib.withNarKey files-watcher "nixosModule") 25 (my-lib.lib.withNarKey files-watcher "nixosModule")
22 (my-lib.lib.withNarKey opendmarc "nixosModule") 26 (my-lib.lib.withNarKey opendmarc "nixosModule")
23 #FIXME: 27 (my-lib.lib.withNarKey secrets "nixosModule")
24 #(my-lib.lib.withNarKey secrets "nixosModule")
25 ]; 28 ];
26 config = lib.mkIf (name == name') { 29 config = lib.mkIf (name == name') {
27 users.users."${config.services.opendmarc.user}".extraGroups = [ "keys" ]; 30 users.users."${config.services.opendmarc.user}".extraGroups = [ "keys" ];