aboutsummaryrefslogtreecommitdiff
path: root/flakes/private/opendmarc/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/private/opendmarc/flake.nix')
-rw-r--r--flakes/private/opendmarc/flake.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/flakes/private/opendmarc/flake.nix b/flakes/private/opendmarc/flake.nix
index 384bf98..3d500a2 100644
--- a/flakes/private/opendmarc/flake.nix
+++ b/flakes/private/opendmarc/flake.nix
@@ -3,10 +3,13 @@
3 path = "../../opendmarc"; 3 path = "../../opendmarc";
4 type = "path"; 4 type = "path";
5 }; 5 };
6 inputs.nixpkgs.url = "github:NixOS/nixpkgs"; 6 inputs.nix-lib.url = "github:NixOS/nixpkgs";
7
8 # Necessary for dependencies
9 inputs.nixpkgs.follows = "opendmarc/nixpkgs";
7 10
8 description = "Private configuration for opendmarc"; 11 description = "Private configuration for opendmarc";
9 outputs = { self, nixpkgs, opendmarc }: 12 outputs = { self, nix-lib, opendmarc, nixpkgs }:
10 let 13 let
11 cfg = name': { config, lib, pkgs, name, ... }: lib.mkIf (name == name') { 14 cfg = name': { config, lib, pkgs, name, ... }: lib.mkIf (name == name') {
12 users.users."${config.services.opendmarc.user}".extraGroups = [ "keys" ]; 15 users.users."${config.services.opendmarc.user}".extraGroups = [ "keys" ];
@@ -54,6 +57,6 @@
54 }; 57 };
55 in 58 in
56 opendmarc.outputs // 59 opendmarc.outputs //
57 { nixosModules = opendmarc.nixosModules or {} // nixpkgs.lib.genAttrs ["eldiron" "backup-2"] cfg; }; 60 { nixosModules = opendmarc.nixosModules or {} // nix-lib.lib.genAttrs ["eldiron" "backup-2"] cfg; };
58} 61}
59 62