aboutsummaryrefslogtreecommitdiff
path: root/flakes/private/environment/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/private/environment/flake.nix')
-rw-r--r--flakes/private/environment/flake.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/flakes/private/environment/flake.nix b/flakes/private/environment/flake.nix
index 50df449..4321fa8 100644
--- a/flakes/private/environment/flake.nix
+++ b/flakes/private/environment/flake.nix
@@ -138,14 +138,6 @@
138 ''; 138 '';
139 }; 139 };
140 isVm = mkEnableOption "The host is a vm"; 140 isVm = mkEnableOption "The host is a vm";
141 users = mkOption {
142 type = unspecified;
143 default = pkgs: [];
144 description = ''
145 Sublist of users from realUsers. Function that takes pkgs as
146 argument and gives an array as a result
147 '';
148 };
149 emails = mkOption { 141 emails = mkOption {
150 default = []; 142 default = [];
151 description = "List of e-mails that the server can be a sender of"; 143 description = "List of e-mails that the server can be a sender of";
@@ -345,14 +337,6 @@
345 }; 337 };
346 }; 338 };
347 }; 339 };
348 realUsers = mkOption {
349 description = ''
350 Attrset of function taking pkgs as argument.
351 Real users settings, should provide a subattr of users.users.<name>
352 with at least: name, (hashed)Password, shell
353 '';
354 type = attrsOf unspecified;
355 };
356 users = mkOption { 340 users = mkOption {
357 description = "System and regular users uid/gid"; 341 description = "System and regular users uid/gid";
358 type = attrsOf (submodule { 342 type = attrsOf (submodule {