aboutsummaryrefslogtreecommitdiff
path: root/flakes/private/environment/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/private/environment/flake.nix')
-rw-r--r--flakes/private/environment/flake.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/flakes/private/environment/flake.nix b/flakes/private/environment/flake.nix
index 9df316d..9305f66 100644
--- a/flakes/private/environment/flake.nix
+++ b/flakes/private/environment/flake.nix
@@ -321,6 +321,34 @@
321 options = ldapOptions; 321 options = ldapOptions;
322 }; 322 };
323 }; 323 };
324 wireguard = mkOption {
325 description = "Wireguard networks configuration";
326 default = {};
327 type = attrsOf (submodule {
328 options = {
329 subnet = mkOption {
330 type = str;
331 description = "Subnet to use for this network";
332 };
333 subnetLength = mkOption {
334 type = str;
335 description = "Subnet length for this network";
336 };
337 devices = mkOption {
338 description = "Devices part of this network";
339 type = attrsOf (submodule {
340 options = {
341 public = mkOption { type = nullOr str; default = null; description = "Public key of the host"; };
342 internalHost = mkEnableOption "Refer to internal host configuration";
343 externalIp = mkOption { type = nullOr str; default = null; description = "external ip to contact"; };
344 ip = mkOption { type = str; description = "ip suffix to use"; };
345 port = mkOption { type = nullOr port; description = "port to listen to"; default = null; };
346 };
347 });
348 };
349 };
350 });
351 };
324 databases = mkOption { 352 databases = mkOption {
325 description = "Databases configuration"; 353 description = "Databases configuration";
326 type = submodule { 354 type = submodule {