aboutsummaryrefslogtreecommitdiff
path: root/flakes/opendmarc/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/opendmarc/flake.nix')
-rw-r--r--flakes/opendmarc/flake.nix10
1 files changed, 2 insertions, 8 deletions
diff --git a/flakes/opendmarc/flake.nix b/flakes/opendmarc/flake.nix
index 469cf74..f1877b6 100644
--- a/flakes/opendmarc/flake.nix
+++ b/flakes/opendmarc/flake.nix
@@ -6,18 +6,12 @@
6 type = "git"; 6 type = "git";
7 dir = "flakes/myuids"; 7 dir = "flakes/myuids";
8 }; 8 };
9 inputs.libspf2 = {
10 url = "https://git.immae.eu/perso/Immae/Config/Nix.git";
11 type = "git";
12 dir = "flakes/libspf2";
13 inputs.nixpkgs.follows = "nixpkgs";
14 };
15 inputs.flake-utils.url = "github:numtide/flake-utils"; 9 inputs.flake-utils.url = "github:numtide/flake-utils";
16 inputs.nixpkgs.url = "github:NixOS/nixpkgs"; 10 inputs.nixpkgs.url = "github:NixOS/nixpkgs";
17 11
18 outputs = { self, myuids, libspf2, flake-utils, nixpkgs }: flake-utils.lib.eachSystem ["aarch64-linux" "i686-linux" "x86_64-linux"] (system: 12 outputs = { self, myuids, flake-utils, nixpkgs }: flake-utils.lib.eachSystem ["aarch64-linux" "i686-linux" "x86_64-linux"] (system:
19 let 13 let
20 pkgs = import nixpkgs { inherit system; overlays = [ libspf2.overlay ]; }; 14 pkgs = import nixpkgs { inherit system; overlays = []; };
21 in rec { 15 in rec {
22 packages.opendmarc = pkgs.callPackage ./. {}; 16 packages.opendmarc = pkgs.callPackage ./. {};
23 defaultPackage = packages.opendmarc; 17 defaultPackage = packages.opendmarc;