aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/webapps
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/mypackages/pkgs/webapps')
-rw-r--r--flakes/mypackages/pkgs/webapps/mantisbt_2/default.nix19
-rw-r--r--flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/mantis-kanban/default.nix19
-rw-r--r--flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/taskodrome/default.nix19
-rw-r--r--flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/tasks/default.nix18
4 files changed, 66 insertions, 9 deletions
diff --git a/flakes/mypackages/pkgs/webapps/mantisbt_2/default.nix b/flakes/mypackages/pkgs/webapps/mantisbt_2/default.nix
index 466595d..942e32c 100644
--- a/flakes/mypackages/pkgs/webapps/mantisbt_2/default.nix
+++ b/flakes/mypackages/pkgs/webapps/mantisbt_2/default.nix
@@ -1,6 +1,6 @@
1{ mantis_config ? "/etc/mantisbt/config_inc.php", stdenv, fetchurl, lib, callPackage}: 1{ mantis_config ? "/etc/mantisbt/config_inc.php", stdenv, fetchurl, lib, callPackage}:
2let 2let
3 pluginNames = [ "slack" "source-integration" ]; 3 pluginNames = [ "slack" "source-integration" "taskodrome" "mantis-kanban" "tasks" ];
4 allPlugins = lib.attrsets.genAttrs pluginNames 4 allPlugins = lib.attrsets.genAttrs pluginNames
5 (name: callPackage (./plugins + "/${name}") {}); 5 (name: callPackage (./plugins + "/${name}") {});
6 toPassthru = pkg: plugins: { 6 toPassthru = pkg: plugins: {
@@ -23,17 +23,18 @@ let
23 in newMantisbt; 23 in newMantisbt;
24 package = stdenv.mkDerivation rec { 24 package = stdenv.mkDerivation rec {
25 name = "mantisbt-${version}"; 25 name = "mantisbt-${version}";
26 version = "2.21.0"; 26 version = "2.26.1";
27 src = fetchurl { 27 src = fetchurl {
28 url = "https://downloads.sourceforge.net/project/mantisbt/mantis-stable/${version}/${name}.tar.gz"; 28 url = "https://downloads.sourceforge.net/project/mantisbt/mantis-stable/${version}/${name}.tar.gz";
29 sha256 = "13lx569dp1gibq5daqp7dj6gsqic85rrix1s7xkp60gwpzk8wiw5"; 29 sha256 = "sha256-poJCEjq+yB2RbA0k5go899mBGBXewjLZHGFmabrCYW4=";
30 }; 30 };
31 patches = [ 31 # FIXME: captcha for anonymous
32 ./bug_report.php.diff 32 #patches = [
33 ./bug_report_page.php.diff 33 # ./bug_report.php.diff
34 ./bugnote_add.php.diff 34 # ./bug_report_page.php.diff
35 ./bugnote_add_inc.php.diff 35 # ./bugnote_add.php.diff
36 ]; 36 # ./bugnote_add_inc.php.diff
37 #];
37 installPhase = '' 38 installPhase = ''
38 cp -a . $out 39 cp -a . $out
39 ln -s ${mantis_config} $out/config/config_inc.php 40 ln -s ${mantis_config} $out/config/config_inc.php
diff --git a/flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/mantis-kanban/default.nix b/flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/mantis-kanban/default.nix
new file mode 100644
index 0000000..1d51705
--- /dev/null
+++ b/flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/mantis-kanban/default.nix
@@ -0,0 +1,19 @@
1{ stdenv, fetchFromGitHub }:
2stdenv.mkDerivation rec {
3 version = "v2.1.0";
4 name = "mantisbt-plugin-kanban-${version}";
5 src = fetchFromGitHub {
6 owner = "mantisbt-plugins";
7 repo = "MantisKanban";
8 rev = "62c3815578cab8a7766580049c3a4f5968331231";
9 sha256 = "sha256-wvinh7+QjsCEk05LHCL1KfTy/3+PvnVYwduHq2hlQP0=";
10 };
11 installPhase = ''
12 mkdir $out
13 cp -a * $out/
14 '';
15 passthru = {
16 pluginName = "MantisKanban";
17 };
18}
19
diff --git a/flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/taskodrome/default.nix b/flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/taskodrome/default.nix
new file mode 100644
index 0000000..dcf0d93
--- /dev/null
+++ b/flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/taskodrome/default.nix
@@ -0,0 +1,19 @@
1{ stdenv, fetchFromGitHub }:
2stdenv.mkDerivation rec {
3 version = "v2.1.8";
4 name = "mantisbt-plugin-taskodrome-${version}";
5 src = fetchFromGitHub {
6 owner = "mantisbt-plugins";
7 repo = "Taskodrome";
8 rev = "d8e24a0991f58a902c6c5cf9e88132a17ad533ac";
9 sha256 = "sha256-Jp2ROIjcSFTtGC58sDUg4FaB3mOKbY3GGpnIQqSpUaY=";
10 };
11 installPhase = ''
12 mkdir $out
13 cp -a Taskodrome $out/
14 '';
15 passthru = {
16 pluginName = "Taskodrome";
17 selector = "Taskodrome";
18 };
19}
diff --git a/flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/tasks/default.nix b/flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/tasks/default.nix
new file mode 100644
index 0000000..fe842f4
--- /dev/null
+++ b/flakes/mypackages/pkgs/webapps/mantisbt_2/plugins/tasks/default.nix
@@ -0,0 +1,18 @@
1{ stdenv, fetchFromGitHub }:
2stdenv.mkDerivation rec {
3 version = "v3.30";
4 name = "mantisbt-plugin-tasks-${version}";
5 src = fetchFromGitHub {
6 owner = "mantisbt-plugins";
7 repo = "Tasks";
8 rev = "38d8255aa989b914ec0730e58ca73708d07f35c3";
9 sha256 = "sha256-QDMa8ar/FEpJCSH1D9LEaXSDR+WRkDx3stXm2+LKO0Q=";
10 };
11 installPhase = ''
12 mkdir $out
13 cp -a * $out/
14 '';
15 passthru = {
16 pluginName = "Tasks";
17 };
18}