diff options
Diffstat (limited to 'flakes/mypackages/pkgs/webapps/roundcubemail/plugins')
8 files changed, 56 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/automatic_addressbook/default.nix b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/automatic_addressbook/default.nix new file mode 100644 index 0000000..cd9efee --- /dev/null +++ b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/automatic_addressbook/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "automatic_addressbook"; | ||
4 | version = "0.4.3"; | ||
5 | url = "https://github.com/sblaisot/${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "0bx5qjzp3a3wc72fr295bvgsy5n15949c041hq76n6c7sqdn7inc"; | ||
7 | } | ||
diff --git a/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/carddav/default.nix b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/carddav/default.nix new file mode 100644 index 0000000..ad6856b --- /dev/null +++ b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/carddav/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "carddav"; | ||
4 | version = "3.0.3"; | ||
5 | url = "https://github.com/blind-coder/rcmcarddav/releases/download/v${version}/${appName}-${version}.tar.bz2"; | ||
6 | sha256 = "0cf5rnqkhhag2vdy808zfpr4l5586fn43nvcia8ac1ha58azrxal"; | ||
7 | } | ||
diff --git a/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/contextmenu/default.nix b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/contextmenu/default.nix new file mode 100644 index 0000000..34a43a7 --- /dev/null +++ b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/contextmenu/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "contextmenu"; | ||
4 | version = "3.2"; | ||
5 | url = "https://github.com/johndoh/roundcube-${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "1j7qns42bvgwav8d5n8g16iajyrhydd76hgil8625f3xyjbv4mx0"; | ||
7 | } | ||
diff --git a/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/contextmenu_folder/default.nix b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/contextmenu_folder/default.nix new file mode 100644 index 0000000..e5cb46d --- /dev/null +++ b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/contextmenu_folder/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "contextmenu_folder"; | ||
4 | version = "1.3.3"; | ||
5 | url = "https://github.com/random-cuber/${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "1ngfws1v8qrpa52rjh7kirc98alchk2vbqwra86h00agyjjlcc57"; | ||
7 | } | ||
diff --git a/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/html5_notifier/default.nix b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/html5_notifier/default.nix new file mode 100644 index 0000000..a5788b3 --- /dev/null +++ b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/html5_notifier/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "html5_notifier"; | ||
4 | version = "v0.6.4"; | ||
5 | url = "https://github.com/stremlau/${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "1w6xkffgxwbahi7acixdh5sgjvsjlfwdq942gkvc64byk8r3bhsj"; | ||
7 | } | ||
diff --git a/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/ident_switch/default.nix b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/ident_switch/default.nix new file mode 100644 index 0000000..3e10fee --- /dev/null +++ b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/ident_switch/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "ident_switch"; | ||
4 | version = "4.2"; | ||
5 | url = "https://bitbucket.org/BoresExpress/${appName}/get/${version}.tar.gz"; | ||
6 | sha256 = "0rf2krjsnly4i0mzgsbx09xckr3p9a9dzxf8qq4lkyng1a7dvjkq"; | ||
7 | } | ||
diff --git a/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/message_highlight/default.nix b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/message_highlight/default.nix new file mode 100644 index 0000000..dc7138a --- /dev/null +++ b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/message_highlight/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "message_highlight"; | ||
4 | version = "4.4"; | ||
5 | url = "https://github.com/corbosman/${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "12c4x47y70xdl5pgm8csh5i4yiyhpi232lvjbixmca6di4lkhh9j"; | ||
7 | } | ||
diff --git a/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/thunderbird_labels/default.nix b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/thunderbird_labels/default.nix new file mode 100644 index 0000000..b67f16a --- /dev/null +++ b/flakes/mypackages/pkgs/webapps/roundcubemail/plugins/thunderbird_labels/default.nix | |||
@@ -0,0 +1,7 @@ | |||
1 | { buildPlugin }: | ||
2 | buildPlugin rec { | ||
3 | appName = "thunderbird_labels"; | ||
4 | version = "v1.4.2"; | ||
5 | url = "https://github.com/mike-kfed/roundcube-${appName}/archive/${version}.tar.gz"; | ||
6 | sha256 = "00dqqlq6m8a6dwynp6gwfimc10anbs8kh0qdy8xvq2l06hk6jxyc"; | ||
7 | } | ||