diff options
Diffstat (limited to 'flakes/mypackages/pkgs/webapps/roundcubemail/default.nix')
-rw-r--r-- | flakes/mypackages/pkgs/webapps/roundcubemail/default.nix | 20 |
1 files changed, 9 insertions, 11 deletions
diff --git a/flakes/mypackages/pkgs/webapps/roundcubemail/default.nix b/flakes/mypackages/pkgs/webapps/roundcubemail/default.nix index a786e86..f83e61b 100644 --- a/flakes/mypackages/pkgs/webapps/roundcubemail/default.nix +++ b/flakes/mypackages/pkgs/webapps/roundcubemail/default.nix | |||
@@ -1,6 +1,6 @@ | |||
1 | { varDir ? "/var/lib/roundcubemail" | 1 | { varDir ? "/var/lib/roundcubemail" |
2 | , roundcube_config ? "/etc/roundcube/config.php" | 2 | , roundcube_config ? "/etc/roundcube/config.php" |
3 | , stdenv, fetchurl, jre, unzip, lib, callPackage }: | 3 | , stdenv, fetchurl, which, nodePackages, lib, callPackage }: |
4 | let | 4 | let |
5 | defaultInstall = '' | 5 | defaultInstall = '' |
6 | mkdir -p $out | 6 | mkdir -p $out |
@@ -52,22 +52,20 @@ let | |||
52 | passthru = toPassthru newRoundcube pkg.plugins (pkg.skins ++ skins); | 52 | passthru = toPassthru newRoundcube pkg.plugins (pkg.skins ++ skins); |
53 | }); | 53 | }); |
54 | in newRoundcube; | 54 | in newRoundcube; |
55 | shrinker = fetchurl { | ||
56 | url = "https://dl.google.com/closure-compiler/compiler-20200719.zip"; | ||
57 | sha256 = "0j46y9ack2yq67naca6nfysbmyilwjlkl29dbswidf1lq09yhhj3"; | ||
58 | }; | ||
59 | package = stdenv.mkDerivation rec { | 55 | package = stdenv.mkDerivation rec { |
60 | version = "1.4.15"; | 56 | version = "1.6.8"; |
61 | name = "roundcubemail-${version}"; | 57 | name = "roundcubemail-${version}"; |
62 | src= fetchurl { | 58 | src= fetchurl { |
63 | url = "https://github.com/roundcube/roundcubemail/releases/download/${version}/${name}-complete.tar.gz"; | 59 | url = "https://github.com/roundcube/roundcubemail/releases/download/${version}/${name}-complete.tar.gz"; |
64 | sha256 = "sha256-0CRVGmPCjMOUPEELpWk93TifchXUbzhUvS55IOgaAh8="; | 60 | sha256 = "sha256-hGi+AgSnNMV0re9L4BV4x9xPq5wv40ADvzQaK9IO/So="; |
65 | }; | 61 | }; |
66 | patches = [ ./add_all.patch ]; # This patch includes js modification which requires to re-run the jsshrink below | 62 | patches = [ |
67 | buildInputs = [ unzip jre ]; | 63 | ./add_all.patch # This patch includes js modification which requires to re-run the jsshrink below |
64 | ./md5.patch | ||
65 | ]; | ||
66 | buildInputs = [ which nodePackages.uglify-js ]; | ||
68 | buildPhase = '' | 67 | buildPhase = '' |
69 | mkdir -p /tmp | 68 | sed -i -e "s/uglify-js/uglifyjs/g" ./bin/jsshrink.sh |
70 | unzip -p "${shrinker}" "*.jar" > "/tmp/compiler.jar" | ||
71 | ./bin/jsshrink.sh | 69 | ./bin/jsshrink.sh |
72 | sed -i \ | 70 | sed -i \ |
73 | -e "s|RCUBE_INSTALL_PATH . 'temp.*|'${varDir}/cache';|" \ | 71 | -e "s|RCUBE_INSTALL_PATH . 'temp.*|'${varDir}/cache';|" \ |