diff options
Diffstat (limited to 'flakes/mypackages/pkgs/gearmand')
-rw-r--r-- | flakes/mypackages/pkgs/gearmand/default.nix | 16 |
1 files changed, 16 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/gearmand/default.nix b/flakes/mypackages/pkgs/gearmand/default.nix new file mode 100644 index 0000000..14ef8c2 --- /dev/null +++ b/flakes/mypackages/pkgs/gearmand/default.nix | |||
@@ -0,0 +1,16 @@ | |||
1 | { stdenv, fetchurl, boost, gperf, libevent, libmysqlclient, libuuid, sqlite, hiredis, postgresql, openssl }: | ||
2 | stdenv.mkDerivation rec { | ||
3 | pname = "gearmand"; | ||
4 | version = "1.1.20"; | ||
5 | src = fetchurl { | ||
6 | url = "https://github.com/gearman/${pname}/releases/download/${version}/${pname}-${version}.tar.gz"; | ||
7 | sha256 = "sha256-L2D6IH3NcwWV75ap3DyomVZnB8gXYQazxj7PR+3BR6Y="; | ||
8 | }; | ||
9 | buildInputs = [ boost gperf libevent openssl libmysqlclient libuuid sqlite hiredis postgresql ]; | ||
10 | configureFlags = [ | ||
11 | "--with-boost=${boost.dev}" | ||
12 | "--with-boost-libdir=${boost}/lib" | ||
13 | "--with-openssl=${openssl.dev}" | ||
14 | "--enable-ssl" | ||
15 | ]; | ||
16 | } | ||