aboutsummaryrefslogtreecommitdiff
path: root/flakes/lib/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flakes/lib/flake.nix')
-rw-r--r--flakes/lib/flake.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/flakes/lib/flake.nix b/flakes/lib/flake.nix
index 5b78fb6..b5bd7ee 100644
--- a/flakes/lib/flake.nix
+++ b/flakes/lib/flake.nix
@@ -2,8 +2,7 @@
2 inputs.nixpkgs.url = "github:NixOS/nixpkgs"; 2 inputs.nixpkgs.url = "github:NixOS/nixpkgs";
3 inputs.flake-parts.url = "github:hercules-ci/flake-parts"; 3 inputs.flake-parts.url = "github:hercules-ci/flake-parts";
4 inputs.disko.url = "github:nix-community/disko"; 4 inputs.disko.url = "github:nix-community/disko";
5 # replace with zhaofengli/colmena once https://github.com/zhaofengli/colmena/pull/161 is merged 5 inputs.colmena.url = "github:zhaofengli/colmena";
6 inputs.colmena.url = "github:immae/colmena/add-lib-get-flake";
7 inputs.nixos-anywhere.url = "github:numtide/nixos-anywhere"; 6 inputs.nixos-anywhere.url = "github:numtide/nixos-anywhere";
8 inputs.nixos-anywhere.inputs.disko.follows = "disko"; 7 inputs.nixos-anywhere.inputs.disko.follows = "disko";
9 inputs.nixos-anywhere.inputs.flake-parts.follows = "flake-parts"; 8 inputs.nixos-anywhere.inputs.flake-parts.follows = "flake-parts";
@@ -45,11 +44,11 @@
45 44
46 }; 45 };
47 flake = { 46 flake = {
48 nixosConfigurations.${name} = (colmena.lib.fromRawFlake self).nodes.${name}; 47 nixosConfigurations.${name} = (colmena.lib.makeHive self.outputs.colmena).nodes.${name};
49 nixosConfigurations."${name}WithEncryption" = let 48 nixosConfigurations."${name}WithEncryption" = let
50 selfWithEncryption = nixpkgs.lib.recursiveUpdate self { outputs.colmena.meta.specialArgs.cryptKeyFile = "/run/decrypt-key"; }; 49 selfWithEncryption = nixpkgs.lib.recursiveUpdate self { outputs.colmena.meta.specialArgs.cryptKeyFile = "/run/decrypt-key"; };
51 in 50 in
52 (colmena.lib.fromRawFlake selfWithEncryption).nodes.${name}; 51 (colmena.lib.makeHive selfWithEncryption.outputs.colmena).nodes.${name};
53 colmena = { 52 colmena = {
54 meta.nixpkgs = nixpkgs.legacyPackages.${system}; 53 meta.nixpkgs = nixpkgs.legacyPackages.${system};
55 meta.specialArgs = moduleArgs; 54 meta.specialArgs = moduleArgs;